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Preface 
 

How to Use This Guide 

 

 

Purpose of This Guide The Leadscope Client User Guide details procedures for using the 

Leadscope client software. 

 

Audience This guide is intended for end-users of the Leadscope client. 

Text Conventions This guide uses the following conventions: 

¶ Bold indicates user action. For example: 

Click the OK button. 

¶ Italic text indicates new or important words and is also used for 

emphasis. For example: 

 

Prior to proceeding, always check you have selected the set to 

analyze. 

 

¶ A right arrow (Č) separates successive commands you select from 

a drop-down or shortcut menu. For example: 

 

Select File Č OpenČ Project 

User Attention Words Two user attention words appear in Leadscope user 

documentation. Each word implies a particular level of observation 

or action as described below: 

 

Note: Provides information that may be of interest or help but is 

not critical to the use of the product. 
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IMPORTANT! Provides information that is necessary for proper 

operation, use, or best practices for the Leadscope® Client 

application. 

 

 

 

 

  

Contacting Leadscope 

 

 

How to 

Obtain 

Services and 

Support 

The latest support information is available online at 

www.leadscope.com/support . You can also contact Leadscope 

Technical Support directly: 

 

support@leadscope.com 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.leadscope.com/support
mailto:support@leadscope.com
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CHAPTER 1 
 

 

 
 

Getting Started 
 

 

Included in this chapter: 

 

¶ Overview 

¶ New Features in the latest Leadscope release 

¶ Before You Install the Leadscope Client 

¶ Launching the Software for the First Time 
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Overview 

The mission of Leadscope is to assist in the development and safety assessment of chemical products with 

improved efficacy, decreased toxicity, and minimal side effects. The Leadscope platform helps scientists 

analyze in vitro and in vivo data, develop structure-activity relationships, and assemble predictive models. To 

this end, Leadscope has engineered a chemoinformatics data-mining platform along with add-in application 

modules, content databases, and predictive model suites. Leadscope is currently used by scientists in 

government, academia, and private industry from discovery through regulatory review and stewardship of 

drug and chemical products. 
 

There are three variants of the Leadscope chemical data mining application: 1) Enterprise, 2) Hosted and 3) 

Personal. Leadscope® Enterprise (LSE) consists of a Server application running on an application server and 

accessing a separate relational database and one or more Client applications running on desktop PCs. The 

Enterprise database on the Server houses the necessary chemical structures and associated data from your 

central corporate databases. The Enterprise database is shared by many users and is supported by a 

professional IT staff. You can also store structures and data in the Client’s Personal database. The Personal 

database is embedded in the Client running on your PC and can be accessed only by you – it is your workspace 

and your responsibility to maintain. The structures and data sets imported into the Enterprise or Personal 

databases are analyzed and used by informatics tools available in the Project Browser. The Project Browser 

interface is the interactive sandbox at the heart of Leadscope. Groups of chemicals and structures can be 

associated to form a project and are then available to data mine in the Project Browser. The structures and 

data in either database are available to any project created in that database. 
 

Leadscope® Hosted (LSH) shares the same architecture with LSE, the difference being that the Client connects 

to the Server remotely using a secured connection. 
 

Leadscope® Personal (LSP) is a standalone version of the LSE Client and includes only the local Personal 

database. 
 

New Features and Updates in Leadscope Version 3.8 

Integrated Hazard Assessment for Genetox and Skin Sensitization Protocols 

Since 2016, Leadscope scientists have led an international consortium of over 60 organizations to 

develop in silico toxicology (IST) protocols (similar to in vitro or in vivo test guidelines). In 2018, the 

project published a framework for in silico toxicology protocols, with the first protocol for genetic 

toxicology published in 2019 following by a protocol for skin sensitization in 2020. This Leadscope 

software version now includes a complete implementation of these published protocols by providing 

immediate access to computation methodologies and toxicity databases outlined in the protocols. 

These are incorporated within a visual decision framework that combines all information, both 

experiment data and in silico results, in a manner consistent with the weight-of-evidence principles 

outlined in the protocols. This interactive framework includes the ability to inspect and perform an 

expert review of the experiment data and/or predictions at any point alongside an assessment of how 
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the information was combined into an overall assessment and associated confidence score. This 

implementation supports the application of good in silico practices in the assessment of genetic 

toxicity and skin sensitization.  

 

Genetox Expert Alerts Update (version 7) 

The Leadscope Genetox Expert Alerts have been updated with knowledge shared from corporate 

sponsors over the past year through the Leadscope knowledge-sharing program. This program allowed 

examination of proprietary corporate information under confidentiality restrictions through the use of 

Leadscope SAR fingerprints designed to elucidate SARs for specific compound classes.  

 

Major changes have been made to the organohalides in this release based on an analysis of proprietary 

databases alongside a thorough assessment of the literature related to their mechanisms. This includes 

new alerts covering: primary alkyl halides, aryl methyl halide, allylic halides, geminal dihalides, tri-halo 

derivatives, alpha-halo carbonyl derivatives, halogenated methanes, halogenated nitromethanes, 

secondary alkyl halide, miscellaneous group, haloalkenes and halo pyridines. 

 

Minor changes have been made to the structural (activating) definitions of the following alerts: 46: 

polycyclic aromatic system, 61: isocyanate, 135: 2-4-5-triphenyl-2-imidazolines-and-related, 140: 

dibenzofuran-and-related, 152: terminal non-aryl hydrazine, 159: unhindered epoxide, 165: aliphatic 

terminal hydrazine, 227: 7-oxabicyclo[4.1.0]heptane, 243: dialkyl sulfamates and sulfates, 357: alpha, 

beta unsaturated aldehyde (high molecular weight), 369: [substituted] alkylaldehyde oxime. Minor 

changes have been made to the structural (deactivating) definitions of the following alerts: 22: aromatic 

nitro, 24: aziridine, 383: alpha-halo amide. Non-structural definition updates have been made for: 110: 

aryl boronic acids, 334: strong activating aryl boronic acid. 

 

Starting in early 2020, Leadscope participated in an industry workgroup studying N-

Nitrosamines structure-activity relationships. This resulted in a publication and updates to existing N-

Nitrosamines alert 28: nitrosamine, 34: N-nitroso-N-dialkylamines acyclic improving both their 

sensitivity and specificity. 

The response statistics of individual and combinations of bacterial mutation tester strains have been 

updated for the alerts reflecting updates to the alert definitions and Alert Reference Set data. 
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Skin Sensitization Model Updates (version 2) 

The skin sensitization suite supports the implementation of the skin sensitization protocol and 

provides an assessment of the following adverse outcome pathway key events: protein reactivity 

(MIE), events in keratinocytes (KE2), activation of dendritic cells (KE3), and lymphocyte proliferation 

(KE4), in addition to providing an assignment to a reactivity domain.  In support of good in silico 

practice, two complimentary methodologies (expert rule-based and statistical models) are now 

offered for the Local Lymph Node Assay (LLNA) prediction. Databases are provided for human 

sensitization (HMT and HRIPT) results and Guinea Pig Maximization Test (GPMT) results. 

 

Bacterial Mutation and Carcinogenicity Database Update 

Additional bacterial mutation data has been harvested (including additional N-nitrosamine literature 

data) and added to the experimental databases searched by the Model Applier. There are now over 

13,000 compounds with bacterial mutation data in the Genetox Level II database, including over 11,000 

with graded bacterial mutation calls. The bacterial mutation grading algorithm has been updated this 

release with study data calls from trusted sources being given preference over literature references. 

Compounds with inconclusive experimental calls (i.e. equivocal and ungraded) are now displayed for 

reference during model application, though are not used for calculating prediction calls. 

 

Additional in vivo carcinogenicity endpoints were added to the Carcinogenicity Level II Database. The 

male/female rat/mouse endpoints now include FDA training set data and represent an aggregation of 

all data. Additional rat, mouse, and rodent endpoints were created by rolling up the lower level calls. 

The TD50 Rat/Mouse CPDB Summary data was added which comprehensively includes both the TD50 

and/or harmonic mean TD50 data. 
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Other Issues 

1. Hyperlinks to defunct NLM ToxNet webpages have now been redirected to specific tox study pages per 

compound of interest in PubChem. 

2. Leadscope Model Applier 3.0 has a new, updated graphical design. 

3. Consensus models representing model or alert predictions of categories have been removed as the 

ability to directly create categorical models and alerts has been incorporated directly into model and 

alert building functionality. The only remaining consensus models involve combining alert and model 

results together in consensus. 

4. Categorical models and alerts have been created for models in Acute, Skin Sensitization, and 

Ecotoxicity suites using existing data and training sets structures. Predictions using the Acute and 

Ecotoxicity suites should remain unchanged. 

5. An explanation feature has been added to the categorical models including a decision tree showing 

categorical results. 

6. Model application now returns matching compound records with data which may not graded (i.e. 

equivocal or having conflicting results) creating a hyperlink to them entitled, “No Call Data Present”. 

Although not used in prediction, such data is reviewable. 

7. Searching for experimental data when matching alerts has been improved to match inorganic salts and 

structures without a valid free form. 

8. New options have been added expanding the analog searching capabilities. 

9. Performance of exact searching of structures has been improved. 

10. Performance of detailed report generation was improved. 

11. Text values can be appended and merged using the Import Wizard or SDF Editor. 

12. Exporting structures from a remote Chemical Dictionary is now fixed.  

13. Text searching limited to Chemical Dictionary text values has been added. 

14. When modifying projects, properties in informatics results cannot be removed from projects. 

15. Allow merging of numeric and text properties in projects with informatics results that are not part of 

the informatics. 

16. Allow pay-per-use customers to update licenses expiring soon during startup. 

17. Documents can only be saved to the database using Leadscope Personal or Enterprise. 

18. Submission reports can now include third-party results. 

19. Pay-per-use account management now uses https when connecting to the Leadscope website. 

20. Structures can now be manually added in a read-across assessment. 

21. Substructures from the feature hierarchy can be used in a read-across assessment. 

22. Existing database studies can be included in a read-across assessment. 

23. JDK 11 now supports Leadscope products (instead of JDK 8). 
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Before You Install the Leadscope Client 

Computer Requirements 

The minimum and preferred PC requirements for the LS Client are listed in Table 1-1. The Client installation 

will also require the ability to write to the Program Files directory, which may require elevated permissions 

on your PC. 
 

Table 1-1: LS Client Requirements 
 

Compone
nt 

Optimum Requirements Minimum Requirements 

 

Computer 

¶ 2GB RAM 
(available) 

¶ 10GB Disk 
Space 

¶ 1.5 GHz dual 

CPU or better 

¶ 1GB RAM 
(available) 

¶ 5GB Disk Space 

¶ 1.0 GHz CPU or 

better 

Operating 

System 

Microsoft® Windows 7, 

8, 8.1, or 10 

Microsoft® Windows XP 
SP3, 7, 8, 8.1, 

or 10 
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Launching the Software for the First Time 

The LS Client is frequently provided by Leadscope pre-configured to include your license file and, if you are 

using LSE or LSH, server connection settings. If you do not have a pre-configured client, you can use the 

following procedure to quickly get up and running. 

 

Select License File The first time the LS Client is run you may be prompted to select a valid 

license file (see Figure 1-2). Click OK and browse to the license file you have 

been provided. 
 

 

Figure 1-2: Import License 

 

 

Server The LSE or LSH Clients will also need to have the server connection details 

entered. To do this, first open the Server Settings window in 

the LS Client (open Tools Č Server Settings) and select the New 

button (Figure 1-3). 

 

 
 

Figure 1-3: Server Settings – specify a new server entry 



8 Leadscope Client User Guide – Version 3.8 

Proprietary and Confidential 

 

Proprietary and Confidential 

 

 

 

 
 

CHAPTER 2 
 

 

 
 

The Leadscope Explorer 
 

 

Included in this chapter: 

 

¶ Overview 

¶ The Tasks View 

¶ The Projects View 

¶ The Search View 

¶ The Structures View 

¶ The Numeric Data View 

¶ The Text Data View 

¶ The Hierarchy Extensions View 
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Overview 

The Leadscope Client will initially open to the Leadscope Explorer interface. The Explorer is where you can 

manage your Leadscope Projects along with the chemical structures and data you have imported to the 

Leadscope server or your Personal database. You can also search the Leadscope Server or the Personal 

Database and quickly link to common tasks. 
 

The Explorer interface is divided into several different Views including Tasks, Projects, Search, Numeric Data, 

Text Data, Binning Schemes, and Hierarchy Extensions. You can browse the Views using the View Bar (Figure 

2-1). 

 

 

Figure 2-1: The Leadscope Explorer View Bar 
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The initial View displayed is the Tasks View, where you can access shortcuts to common tasks (Figure 2-2). 

 

Figure 2-2: Tasks View 

Each of the Explorer’s Views includes a menu bar, a toolbar specific to the selected view, a sidebar  with the 

list of available views – the View Bar, and the large central pane with the currently selected View (Figure 2-3). 

The menu bar and sidebar remain consistent across all of the views while main View pane and toolbar will 

change. 
 

 

Figure 2-3: Overview of the Explorer 

Explorer Menu Bar 

The categories of the Explorer Menu Bar are consistent across all Explorer Views. Only the File menu option 

has contextual options specific to the current View. 
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The Menu Bar categories include File, Edit, View, Tools, Administration (only if you are a member of the 

Administrators group), and Help (Figure 2-4). 

 

 

Figure 2-4: Explorer Menu Bar 

The File category includes contextual options linked to the current view for creating, deleting, moving, 

exporting, publishing reports, and setting permissions for objects. 

 

The Projects View File menu includes the following 

options specific to that view. 
 

File -> New -> Project – create a new project 

 

File -> Open Classic Project Browser – open the selected 

project in the classic browser 

 

File -> Open Classic Project Compare – open the selected 

projects in the classic compare browser 
 

 

 

 

Figure 2-5: Projects View File menu 

 

 
 

 

Figure 2-6: Structures View File menu 

File -> Delete Unused – delete unused projects in a 

selected folder 

File -> Merge Projects – merge selected projects into a 

new project 

 

 

The Structures View File category includes the following 

structure-specific options: 

 

File -> Delete Unused Source-ids and Structures – delete 

source ids including their associated structures that are 

not in a project for a selected folder 
 

File -> Merge Structure Sources – merge two or more 

selected structure sources into one source 
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The Text Data View File category has the following options for text 

properties. 
 

File -> Delete Unused Text Properties – delete the text properties not in 

a project for a selected folder 

 

 

 

 

 

 

 

Figure 2-7: options under the file men u in the Text Data 

 

 

The Numeric Data View includes the following options for numeric 

properties. 
 

File -> Delete Unused Properties – delete the numeric properties 

not in a project for a selected folder 
 

File -> Merge Datasets – merge the selected datasets into a single 

dataset 

 

 

 

 
Figure 2-8: Numeric Data View File menu 
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Figure 2-9: Binning View 

The Binning View File category includes the following 

options related to binning schemes. 
 

File -> New -> Binning Scheme – create a new binning 

scheme in the selected folder 

 

File -> Delete Unused Binning Schemes – delete the 

binning schemes not used by a numeric property for a 

selected folder 
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Figure 2-10: Hierarchy Extensions View File Menu 

The Hierarchy Extensions View File category has 

the following options for extensions to the 

chemical feature set. 
 

File -> New -> Hierarchy Extension – create a 

new hierarchy extension 
 

File -> New -> Features – add features to an 

existing hierarchy extension 

 

File-> Export -> Feature Definitions – export the 

feature definitions to a SD file for a selected 

hierarchy extension 
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The Edit Menu Bar category includes options to copy, paste, select and unselect all, along with remove and 

undo remove (Figure 2-11). 
 

 

Figure 2-11: Options available in the Edit Menu 

 

The View Menu Bar category allows you to switch between Views, to toggle the View Bar on and off, and 

refresh the current view (Figure 2-12). 
 

 

Figure 2-12:  View MenuThe Tools Menu Bar category includes links to the Import Wizard and 

Test Server Connectivity tools along with the Server Settings and Options dialogs.(Figure 2-

13). 
 

 

Figure 2-13: Tools Menu 
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If you are an Administrator, then you will also see the Administration Menu Bar category. This category 

includes options for managing Users and Groups for a selected Leadscope server (Figure 2-14). 
 

 

Figure 2-14: Administration Menu 

The Help Menu Bar category includes a link to the Leadscope Client User Guide, the Leadscope Database 

Documentation, a hyperlink to www.leadscope.com/ls-manuals to check for the latest documentation, and 

the About screen where you can see your current Leadscope client version and license details (Figure 2-15). 
 

 

Figure 2-15: Help Menu 

 

The Tasks View 

As mentioned previously, the initial View when you first launch the Leadscope Client is the Tasks View. This 

view contains links to frequently performed tasks ranging from maintenance jobs such as importing chemical 

structures and data to advanced informatics analysis jobs such as clustering a set of chemicals, generating 

scaffolds for a group of chemicals, or building predictive models. The list of available tasks is shown in Figure 

2-16. 

 

Figure 2-16: List of available tasks in the Tasks View 

http://www.leadscope.com/ls-manuals
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The Tasks View toolbar (Figure 2-17) includes shortcuts to commonly performed operations, explained in 

detail below. 
 

 

Figure 2-17: Tasks View toolbar 

 

 
 

Refresh this will refresh the client connection to the server and subsequently 

update the client interface with any changes made to the server 
 

Import Wizard launches the Import Wizard tool (see Chapter 4) 

 

SDF Editor launches the SDF Editor application 

 

Apply Models a shortcut to the Model Applier tool 

 

Review Model opens the Predictive Data Miner application to review predictive (Q)SAR 

models loaded on the server 

 

ICH M7 Submissions launches the ICH M7 Submission Expert Review tool 

 

Read-across a shortcut to the read-across tool 
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The Projects View 

When the Projects View is selected (Figure 2-18), the main window is divided into three panes: a View Bar 

(left), a project View Hierarchy (middle) and additional information (right). There is also a Projects View 

toolbar (Figure 2-19). The left pane contains the Projects View. The right pane provides information about a 

selected project or the projects in a folder. To adjust the relative size of the panes, drag the vertical bar that 

divides them. 

 
 

 

Figure 2-18: The Projects View 

The Projects View displays a hierarchy of all currently available folders. There are two top-level folders, one 

for Enterprise projects and one for Personal projects. Enterprise projects are located on the Server and are 

accessible to all users with access permission.  Personal projects are located on your PC and are accessible 

only by you. In the Enterprise folder there will be at a minimum two folders, one named shared accessible by 

all of the users on the system and one named users containing your users folder and accessible only you. 
 

 

 

Figure 2-19: The Projects View toolbar 

Detailed information for a project is available by single-clicking a project in the Projects Hierarchy (Figure 2- 

20). 
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Figure 2-20: The Projects View project details 

Opening a Project 

To begin exploring a set of structures and associated data, open a project from the Explorer window. You can 

do this in a variety of ways. 
 

¶ Double-click the project name in the hierarchy shown in the Projects pane. 

¶ Right-click the project name and then click Open. 

¶ Select the project name, point to the File menu, and then click Open. 

¶ Select the project name, and then click Open on the Explorer toolbar. 

The project will open in a new Project Browser window. 

Creating a Project 

Leadscope Server projects can only be created from compounds and data already loaded to the Server, 

unless being created as a result of importing the structures and/or data with the Import Wizard. Personal 

projects can only be created from compounds and data loaded into the Personal database. To create a new 

folder for your project, first select the parent folder and then either right-click and select New Folder, or 

point to the File menu, choose New, and then click Folder. A folder will be created and named New Folder. 

To rename New Folder, point to the File menu, and then click Rename, or right-click the New Folder. An edit 

box will appear in which you can type the new name. Press Enter. 
 

To create a new project, select the folder where you wish the project to reside. On the File menu, point to 

New, and then click Project (alternatively, right-click the folder and select New Project or enter Ctrl+J). The 

Create Project Wizard will appear in a new window (Figure 2-21). This wizard will guide you through the 
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process of creating project including: adding a source of structures, adding numeric data, adding text data, 

and adding hierarchy extensions to your new project. 
 

 

Figure 2-21: Create Project Wizard 

 

Step 1 - Add Structures 

You can add structures to your new project from any combination of five sources: Projects, Data, Queries, 

IDs and Source IDs. 

 

 

 

To add structures from an existing project, select the Project icon. This will bring up a list of available 

folders and projects. Select the project you wish to use as a source of structures and then click Add in the 

center pane. 

 

 

 

The next choice is to add structures from Data. Click the Data icon to display the numeric data 

loaded into the database. To add all the structures associated with a data set, click the data set name in the 

center pane, and then click Add. 
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The next potential structure source for your new project is from a file containing a list of Structure 

IDs. The structure ID file should be a text file with one ID per line. Click the ID icon to browse to your 

structure ID file. Once this file is opened the ID numbers will appear in the center pane. Select the IDs you 

would like to add to the project (use Ctrl+A to select all of the IDs in the list) and then click Add. 

 

 

The final structure source option is to include all of the structures associated with a Source ID. A 

Source ID is a high-level library tag for a set of structures on the database. Clicking the Source ID icon will 

display all of the Source IDs that are currently used to define structure sets in the database, as shown below. 

To choose the structures corresponding to one of the Source IDs, select its name from the center pane, and 

then click Add. Choose as many sources as you like for adding structures. 
 

Before proceeding to the next step enter the project name at the top of the window. Once you are finished 

adding structures to the project, click Next (Figure 2-22). 

 

 
 

 

Figure 2-22: Step One - Add Structures 
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Step 2 - Add Numeric Data 

In the next step you can add numeric data sets to your project if you wish. It is not required that you add a 

data set to the project (to skip this step simply click Next). All of the numeric data loaded into the database is 

displayed in the center pane. To add a data set, select its name, and then click Add. This will add the data for 

the structures specified in Step 1. If a particular compound does not have a data value corresponding to the 

added data set, the data value will be viewed as empty. The eight Leadscope Calculated Properties are 

automatically added to every project. When you have added the desired data sets, click Next (Figure 2-23) 

 

 

 

Figure 2-23: Step 2 - Add Numeric Data 

 

Step 3 – add text data 

In this step you can add text data sets to your project in the same fashion as adding numeric data in the 

previous step. To add a data set, select the data set from the middle pane and then click Add. Then, click 

Next when you are finished (Figure 2-24). 
 

Note: You can click Finish at this stage if you wish to skip the next two steps. 
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Figure 2-24: Step 3 - Add Text Data 

 

Step 4 - Add Features 

This step of the Create Project Wizard allows you to add Hierarchy Extensions to your project. The extensions 

that are available are shown in folder view in the center pane. To view the structure feature contents of a 

particular folder, double click on the folder. The Hierarchy Extensions within that folder will be displayed. To 

add a particular Hierarchy Extension to your project, select it in the center pane, and then click Add. When 

you have added the desired features, click Next (Figure 2-25). 
 

Note: You cannot add individual features from an extension; the entire extension must be 
added to the project. 

 

 

 

Figure 2-25: Step 4 - Add Hierarchy Extensions 
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Step 5 – Summary 

The final step is a summary screen displaying the elements you have selected in the previous steps to be 

included in your new project. You can add a description of the new project in this step. Click Finish to create 

your project (Figure 2-26). 
 

 

Figure 2-26: Step 5 - Summary 
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Modifying a Project 

A project can be modified to include additional numeric or text data, to remove data, or to change any 

hierarchy extensions associated with the project. There are several ways to begin modifying a project. 
 

¶ Right-click the project name and then click Modify. 

¶ Select the project name, point to the File menu and click Modify. 

¶ Select the project name and enter Shift+F5. 

¶ Select the project name and click the Modify button on the Explorer toolbar. 

 

The Edit Project Wizard will open in a new window. 

 
The figures that follow detail the procedure to add a numeric property, a text property, and a hierarchy 

extension to an existing project with the Edit Project Wizard (Figures 2-27 through 2-28). 
 

Figure 2-27: Edit Project Wizard - Step 1 Modify Data 
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Figure 2-28: Edit Project Wizard - Step 2 Modify Text Data 

 
 

 

Figure 2-29: Edit Project Wizard - Step 3 Modify Features 
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Figure 2-30: Edit Project Wizard - Step 4 Summary 

Deleting a Project 

There are various methods available to delete a project from Leadscope. Deleting a project will remove the 

project object but will not remove the associated structures, data, or hierarchy extensions. 
 

¶ Right-click the project name and select Delete. 

¶ Select the project name and click the Delete button in the toolbar. 

¶ Select the project name and click the Delete key. 

 

Saving Enterprise Projects as Personal Projects 

Any Enterprise project can be saved as a Personal project, providing you with a personal copy of the project 

that cannot be modified by another user. Select an Enterprise project from the Projects View in the Explorer 

window. Select File -> Save as Personal Project. The Enterprise Project will be copied to the Personal folder. 
 

The Search View 

The Search view in the Explorer is used to search for chemical structures loaded into Leadscope. In addition, 

the Search View provides powerful ways of searching Leadscope content modules. 
 

Several methods are available for searching by chemical structure, toxicity study parameters, known drugs 

records, and source of the structures. See Chapter 7 Searching for more detailed information. 

 

To access the Search View from the Explorer window click Search on the View Bar or from the View menu. 
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The Search View includes a toolbar, a search parameters pane, a query editor, and a main pane where the 

query and search results are displayed (Figure 2-31). 

 
 

Figure 2-31: The Search View 

Figure 2-32 shows the actions available in the Search View toolbar. 

 

 

 

Figure 2-32: The Search View toolbar 

Figure 2-33 details the options available in the search parameters pane. 
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Figure 2-33: The Search View search options 

To conduct a search, select a search parameter then enter any options required in the main pane detailing 

the selected search parameter (such as a chemical structure file for structure searching, an ID for name 

searching, or study options). Click the Search button to perform your query. 
 

The Structures View 

The Structures View is where you can manage chemical structures in Leadscope. When a set of structures is 

loaded into Leadscope, it is assigned to a structure source id. The structure source is tagged with a source id 

(such as the name of a chemical library) and associated with a group of structures. Structure sources are 

created when chemical structures are loaded into Leadscope. After a structure source has been created, you 

can move, rename, delete, or merge them (provided you have sufficient permission) in the Structures View. 
 

The Structures View consists of a toolbar, a structure source hierarchy, and a structure source details pane. 

(Figure 2-34) 
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Figure 2-34: The Structures View 

Delete a Structure Source 

To delete a structure source, select it in the structure source hierarchy and then choose the Delete button on 

the toolbar, or right-click the source and select Delete, or select File -> Delete.  A source can only be deleted if 

none of the structures associated with it are in a project. 
 

You can also delete unused structure sources without having to go through the tedium of identifying all of 

the sources that have no chemical structures in projects. To do this, select the folder you wish to check for 

unused sources (select the Enterprise node in LSE or LSH to search the entire Leadscope Server) and then 

choose File->Delete Unused Source-ids and Structures. If there are any unused structure sources, you will 

be able to select and delete them in the dialog that opens. 

 

Merge Structure Sources 

To merge two or more structures sources, select multiple sources using the Ctrl key and then right-click one 

of the sources and select Merge Structure Sources or click File->Merge Structure Sources. A new dialog will 

open prompting you to select the structure source to keep. (Figure 2-35) Select the target source and click 

OK. 
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Figure 2-35: Merging structures sources in the Structures View 

Renaming and Modifying Structure Sources 

To modify a structure source, select the source and choose Modify from the toolbar (you can also right-click 

the source and select Modify or click File->Modify). This will open the Structures Editor dialog where you can 

change the name of the source or enter a description. You can also rename a source by selecting the source 

and then right-clicking and choosing Rename, this will allow you to rename the source in place. 
 

The Numeric Data View 

The Numeric Data view allows you to manage numeric properties in Leadscope. Leadscope differentiates 

between numeric and text endpoints when data sets are loaded. In this view, you can delete, merge, or 

modify numeric properties. 
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Figure 2-36: The Numeric Data View 

Renaming and Modifying Numeric Data 

To modify a numeric endpoint, select the endpoint and pick the Modify button from the toolbar, or click 

Shift+F5, or right-click the endpoint and choose Modify. You should now see the Data Editor window open. 

(Figure 2-37) In this editor, you can re-assign the Binning Scheme associated with a numeric endpoint, 

rename the endpoint, or add a description to the property. 
 

 

Figure 2-37: Data Editor 
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The Text Data View 

The Text Data View is where you can manage text properties in either the Enterprise Server or Personal 

Database (Figure 2-38). 
 

Figure 2-38: The Text Data View 
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The Binning View 

The Binning View is where you can manage schemes associated with numeric properties in either the 

Enterprise Server or Personal database. Binning schemes define how a data set is categorized and every 

numeric property created in Leadscope needs to be associated with a binning scheme.  The categorization 

and binning of data is essential to be able to rapidly filter structures based on the associated data values. The 

cutoffs represented by the bins in a binning scheme are reflected in the Project Browser filters. 
 

 
 

Figure 2-39: The Binning View 

The Binning View has three principal components: the toolbar, the binning scheme hierarchy, and the 

binning scheme details pane (Figure 2-38). 
 

The toolbar actions include Modify, Delete, Refresh, and a link to the Import Wizard. The binning scheme 

hierarchy allows you to browse the binning schemes loaded on the Leadscope Server or in the Personal 

database. The binning scheme details pane will display an overview of the scheme (including the scheme 

cutoffs and labels), the associated numeric property data, creation and modification dates, the owner of the 

scheme, and any descriptive information available for the scheme (Figure 2-39). 
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Figure 2-40: Binning Scheme Details Pane 

Creating a Binning Scheme 

To create a new Binning Scheme, click on the Enterprise or Personal folder in the Binning View, and then 

select File->New->Binning Scheme or right-click the folder and choose New Binning Scheme. This will open a 

new dialog for a new binning scheme. 
 

Enter a name in the Binning Scheme Name 

text box. 

 

Clear the Is Correlating check box if you don’t want to correlate data sets that use this binning scheme with 

structural features. For biological activity data, you will want this box selected. In certain cases, such as the 

Molecular Weight binning scheme, the box is not selected since it doesn’t make sense to correlate features 

with this property. 
 

Choose one of the Each bin is options. Click A discrete value if the values in the data sets fall into discrete 

numeric bins. Select A range of values if the values of the data sets fall into bins with a low and high cutoff. 

For example, the Rotatable Bonds data set has discrete numeric bins, whereas the binning scheme defined 

for IC50 data sets would have bins with “ranges of values” bins. 
 

Choose whether lower or higher numbers are colored to show stronger positive correlation in the When 

showing statistical results list. When displaying the statistical correlation with a property, color is used to 

display chemical features that strongly or negatively correlate with the property. For certain data sets higher 

values indicate higher activity and for other data sets lower values indicate higher activity. It is important to 
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consistently map the higher activity to the same color so that the color’s meaning is understood in the 

visualizations. This setting allows you to do that. If you want to adjust the number of bins and the bin values 

or ranges for each bin, you can edit them using the Bin Editor. Click Edit to open the Bin Editor like the one 

shown in Figure 2-41 below. 
 

 

Figure 2-41: Binning Scheme Editor 

If a binning scheme represents a range of values (for continuous numeric data), two adjacent columns 

represent the low and high values of the range for a bin. The data would fall within the bin if it is more than 

the lower value and less than or equal to the upper value. When a bin represents a discrete value, each bin 

represents a discrete value. Data falls within the bin if its value is the same as the value of the bin.   You set 

the values for the bins in the Cutoffs row. You set the labels to use for the tick marks in the filter in the Labels 

row. You need not label each column. This is helpful if you have a large number of bins and want to label every 

second or third tick mark so that they are legible when displayed on the filter. 
 

To add a bin to the right or left of an existing bin, right-click the column heading  closest  to the bin you want 

to add, and then click Insert Column to Left or Insert Column to Right. A new column will be added. Set the 

cutoff values and enter the label. To set - infinity for the farthest left or + infinity for the farthest right cutoff 

and label, click the appropriate Infinity button. 
 

To remove a bin, right-click the column heading of the bin you want to remove, and then click Remove 

Column. 
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When you are finished editing, click OK to keep your changes and modify the binning scheme for all 

associated data sets. 

 

Click Cancel to discard any changes. 

 

Deleting a Binning Scheme 

To delete a binning scheme, click the Binning Scheme, and then click Delete in the File menu or from the 

toolbar. 
 

The Hierarchy Extensions View 

Hierarchy Extensions are new branches you can add to the base feature hierarchy provided by Leadscope. 

These extensions can be added to projects in either the Enterprise or Personal databases. You use Leadscope 

Explorer to view, manage and add new extensions. To view the feature extensions, click Hierarchy Extensions 

from the View Bar or the View menu. (Figure 2-42) 
 

 

Figure 2-42: Hierarchy Extensions View 

All hierarchy extensions both Personal and those on the Enterprise Server, can be viewed. Each hierarchy 

extension is shown as a folder; each query as a file. Within each folder is the list of named substructure queries 

that make up that branch. Clicking on the sign next to the extension folder expands the folder and displays 

below it in the outline the names of the queries it contains. Clicking on the extension folder displays the queries 

it contains, as shown below. Clicking on a hierarchy extension folder will display a summary view of the branch 

on the right. At the top of the screen, there are some statistics on the hierarchy extension, such as when it 

was created and the project containing this hierarchy extension. 



38 Leadscope Client User Guide – Version 3.8 

Proprietary and Confidential 

 

Proprietary and Confidential 

 

 

 

 

Beneath this information is a grid of all named substructures in this hierarchy extension. On the right, the 

hierarchy extension has been opened and just the names are displayed. To view a detailed description of an 

individual substructure, click on the name in the hierarchy on the left, as shown below. In this view you can 

see the individual substructure search term, including the structure diagram on the left and the additional 

restrictions placed on atoms and bonds on the right. An individual named substructure can be re-named. 

Select the name on the right, right-click and select Rename. 

 

Adding a new Feature Extension 

A new feature hierarchy extension can be added. Selected either the Enterprise or the Personal node on the 

left and then right-click and select New Hierarchy Extension or point to the File menu, choose New, and then 

click Hierarchy Extension. To rename the branch, either single click on the name to retype, then press Enter 

or right-click over the branch and select rename (again once the name has been changed press Enter).  To 

add named substructures to this new branch or any other branch, single click on the branch name, then right- 

click and select New Features. Alternatively, they can be added by clicking Features in the New submenu of 

the File menu. These new substructures must be in a SD file format. The program will use the identification as 

the features name. The following figure shows the dialog to add features. (Figure 2-43) 
 

 

Figure 2-43: New Feature Extension 

To add one or more new named substructure searches to the branch, click on the Query File icon on the left. 

This will initiate a file chooser, where the SD file containing the substructures should be selected. The file will 

then be read in. The list of substructure names will then be displayed in the pane under “Select Features 

from” The location within the SD file of the substructure name can be set using the “Name Location:” pull 

down. Moving your cursor over the name will display the structure diagram in the lower left-hand corner of 

the dialog. One or more substructures can be added to the branch. Select the names you wish to add and 

then add them using the Add button. To add them to the branch, click OK. 
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CHAPTER 3 
 

 

 
 

Security & Permissions 
 

 

Included in this chapter: 

 

¶ Overview 

¶ Your Leadscope ID and User Folder 

¶ Sharing Your Work with Other Users 

¶ Your Leadscope ID and User Folder 
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Overview of Leadscope Security 

The Leadscope Enterprise and Hosted servers include several features related to security including user 

identification and authentication, user and group management, and entity permissions. 

 

The LSE security model is designed to provide optional sharing of Leadscope objects, (specifically projects, 

properties, structures, binning schemes, and folders) between different Leadscope users. It provides object 

authorization based on object owner and group permissions (similar to Unix) and user interface dialogs for 

managing object permissions, users, and user groups. 

 

Object Permissions 

Object permissions include: read, write, and delete permissions. The owner of an object always has full 

permissions on that object. Objects which a user cannot read do not appear the explorer hierarchies and 

cannot be accessed. If a user has read permissions on a folder, he/she can see all objects in that folder (for 

which they also have read permissions). To share an object with other users, the other users must be part of a 

group that can read that object, and the object must be in a folder which the other users can read and 

access. So when an object is to be shared, it will be added to a group by the object owner or administrator 

and given permissions within that group (e.g. read-only). Plus, the object will most likely be moved from a 

private, user folder, to a shared “team” folder. 
 

Read permissions on a project include the ability to open the project as well as see it in the Project Explorer. 

If a user has read permissions on a project the user can read (but not modify) all of the project resources (i.e. 

properties, data, etc.) associated with that project. There are no security restrictions on displaying project 

structures and properties or on the exporting of structures, properties, and fingerprints from within the 

project (even if, for example, the user is restricted from viewing a property outside of the project). In other 

words, the project permissions are assigned to the structures and properties included in the project. 

However, the informatics results (clustering results, predictive models, etc.) associated with a project have 

their own set of permissions. To view or modify the permissions for informatics results right-click the project 

containing the informatics result then select the Manage Informatics Results option. This will open the 

Manage Informatics Results dialog in a separate window (Figure 3-1) where you can select the Permissions 

button for either the folder of results (if you wish to change the ownership/permissions recursively) or for an 

individual result. 
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Figure 3-1: Manage Informatics Results 

The object may be selected for modification (via right-click) and one of these menu-items (or dialog tabs) will 

open a “permissions” dialog. From that dialog, the owner may change the owner of the object, add/remove 

the object from various user groups, and change the permissions on that object within a particular user 

group. When an object is created, only the owner and administrators will have any permission on it until it is 

shared. If an object has group read permissions enabled on it, but the folder the object resides in is not 

readable, the object is not accessible. 
 

There are also security restrictions on structures. These are enabled by setting permissions on the source id 

for a group of structures. Currently, a structure can only have one source id, that is, belong in one group of 

shared structures. 

 

Users 

Authentication must be enabled for the Leadscope server. The end user is then automatically identified by 

their PC login ID which upon successful authentication becomes the user’s Leadscope ID. Users only see 

objects which they can access (i.e., read permission) and can only write/delete objects for which they have 

write or delete permissions, respectively. With read/write permissions, it is possible to be able to change an 

object (e.g. property) but not to delete it. Only the owner of an object (or an administrator) can change the 

owner of an object. 
 

Leadscope Authentication requires the definition of the group of potential LSE users in a domain.  The first 

time any of these users log in to LSE, their user name is added automatically to the Leadscope database and 

user folders are created on the database. The LSE administrator does not have to manually add users. User 

passwords are not stored in the Leadscope database, as authentication is handled outside of the database. A 

user initialization process creates the user, private user folder, and puts the user into the “Everyone” group, 
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etc. If a user wishes to be added to an additional group (to access shared projects, to load chemical 

structures or data, etc.) they must contact an administrator. 

 

Groups 

Users are members in one or more groups. Each group contains a list of users and object permissions. The 

object permissions in a group are associated with each object, not the group as a whole. Therefore, some 

objects in the group may be read-only, while others maybe read/write (though by convention it is easier to 

manage groups if all objects in a group have the same permissions). The “user permissions” a user has for an 

object is determined by the groups he/she is in, and the permissions of that object in that group. If the user is 

the owner of the object, they have full permissions on that object. These permissions are instantiated for the 

user on the client when they log in for all of the objects in all the Explorers. 
 

There are several default groups, pre-seeded on the Leadscope database. 

 

¶ The “Everyone” group – this includes all LSE users and all users have the same permissions for objects 

in the group, (e.g. “everyone read” permissions), though different objects could have varying 

permissions in the group. This is analogous to the “everyone” permissions on a Unix object. 

¶ The “Administrators” group – this include the Leadscope administrators. These users have full access 

to all objects. Additionally, this group determines access to administrator features, specifically, the 

ability to manage Leadscope users, and groups (creating, and adding/subtracting users and object 

permissions). 

¶ The “StructureLoaders” group – a group of users allowed to load and update structures on the 

server. All users can load and update structures on their local database. 

¶ The “DataLoaders” group – a group of users allowed to load and update property data on the server. 

Note that any user permitted to “write” to a property can update the individual structure/property 

values on the database as well as change the property name, etc. All users can load and update data 

on their local database. 

 

Administrators 

Leadscope includes an Administration area where users in the “Administrators” group can administer users 

and groups. This Explorer Menu Bar category is visible if the user is a member of the “Administrators” group. 

The administration category has two options, users and groups, listed below. 
 

ω Users Option: 

 

1. Add/remove users from the system 

2. Add/remove user from various groups 

3. Display and reassign the list of entities owned by a user 

4. Change owner of objects 
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ω Groups Option: 

 

1. Add/remove groups 

2. Add/remove users from a group 

3. Enable/disable a group 

4. Change the group name and description 

 

Administrators are automatically members of the “StructureLoaders” and “DataLoaders” groups, allowing 

them to load and update structures and properties on the Leadscope Server. 

 

All users are allowed to add, modify, and delete feature hierarchy extensions on both the remote or local 

servers. 

 

Structure Search 

Users can search and display all structures loaded for which they have read-permissions.  When displaying the 

structure detail information, only properties which the user has read permissions on will be shown in the 

dialog. 
 

By default, a new user is a member of the “Everyone” group, the group identified by the “CompanyName” 

field in their Leadscope license file, and a group identified by their Leadscope ID.  The Leadscope 

administrator can add end users to additional groups, such as the “StructureLoaders” or “DataLoaders” 

groups. This chapter will cover how Leadscope Hosted and Enterprise users can manage their objects in the 

“users” folder for each of the Leadscope Explorer Views along with how objects (such as projects or data) can 

be shared with other Leadscope users. 

 

Your Leadscope ID and User Folder 

Your Leadscope ID is created the first time you connect to the Leadscope Server based on your local login ID 

on your PC. This user ID is then automatically added to the “Everyone” group, your company’s group, and a 

new group with your ID on the Leadscope Server. Additionally, a “users” folder for your ID is created in the 

Projects, Numeric Data, Text Data, and Binning Schemes Views. For instance, in Figure 3-2 you can see the 

“users” folder for the Leadscope ID “lse”. 
 

 

Figure 3-2: Users folder for 'lse' 
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Sharing Your Work with Other Users 

One of the advantages of the Leadscope networked products – LSE and LSH is the ability to easily share 

chemical structures, data, projects, and saved informatics results associated with projects with other 

Leadscope users. The Leadscope Server products maintain user and group permissions along with an owner 

for all entities and objects created on the server including folders, projects, properties, and binning schemes. 
 

If you wish to modify who can view an entity, browse to the corresponding Explorer View for the object and 

right-click the object and select the Permissions option. For instance, if you wish to add access to all of the 

members of the “Everyone” group to the contents of a folder (projects, data, or binning schemes), right-click 

the folder in the corresponding View and select Permissions. (Figure 3-3) 
 

 

Figure 3-3: The Permissions option on a folder 

This will open the Permissions window, click Add Group Access ... and then select the “Everyone” group and 

click OK. 

 

Note: When modifying the permissions on a folder you can apply the changes recursively to all objects in the 

folder by selecting the Use these permissions for everything contained in folder and subfolders option. 

 

Note: Individual users a treated as groups in Leadscope, so if you wish to add access to an object to 

a user select the group with their user ID. 
 

Figure 3-4 shows the security and permissions options available for objects and folders on the Leadscope 

Server. For any folder or object, you have the ability to change ownership of the object, modify group (and 
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user) access, and assign the permissions for the object associated with a group (or user). 
 

 

 

Figure 3-4: Permissions window 
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CHAPTER 4 
 

 

 
 

Importing Chemical Structures and Data 
 

 

Included in this chapter: 

 

¶ Overview 

¶ Preparing Your Files 

¶ Launching the Import Wizard 

¶ Getting Started 

¶ Step One – Select a File 

¶ Step Two – Choose the File Format 

¶ Step Three – Select the Content to Import 

¶ Step Four – Select Data Types 

¶ Step Five  – Edit Structure IDs 

¶ Step Six – Edit Data 

¶ Step Seven – Select a Database 

¶ Step Eight – Review and Import 
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Overview 

Before you can create projects to explore, you should import a set of chemical structures and data to the 

Leadscope database. The Import Wizard is the client utility for importing files from your PC to the server. It 

was designed as a user-friendly tool for manipulating the input files to the Leadscope Server. Because the 

structures and data you import are shared across all projects, it is important that what gets into the database 

is valid and that you don't accidentally overwrite what is already in the database. The Import Wizard assists 

you with some common data preprocessing tasks. These tasks include cleaning and normalizing your data and 

comparing what you are about to import with what is already in the database before you make changes to the 

database. 
 

This chapter will cover the types of files that can be imported to Leadscope, how to launch the Import 

Wizard 

utility, how to import structures and data with the Import Wizard, and common pitfalls when importing. 

 

Preparing Your Files 

There are three types of files that can be imported with the Import Wizard. They are: 

 

¶ Chemical structure file (.sdf, .mol) 

¶ A SMILES chemical structure spreadsheet file (.txt, smi) 

¶ A text spreadsheet data file (.txt, .csv) 

 

The following table summarizes the features of each of these three file formats: 

 

Table 4-2: File Types 
 

Type Leadscope 
Name 

Extension Contents 

Chemical 
structure 

file 

Structures 

(SDF or 

MOL) 

.sdf, .mol Chemical 
structure
s 

and data 

SMILES 

chemical 

structure 

spreadsh

eet 

file 

Delimited 

Text with 

SMILES 

 

.txt, smi 

Chemical 

structure

s and 

data 
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Text 
spreadsh
eet 
data file 

Delimited 

Text 

.txt, .csv Data 

 

 

Chemical Structure File 

There are many names for this kind of file, Chemical Structure File, SD File, SDF, MOL, etc. It is a commonly 

used format in chemoinformatics and was initially defined by “MDL Information Systems, Inc.” as the CTFile 

format and is currently maintained by Dassault Systèmes BIOVIA. You can download a full explanation of the 

format at http://accelrys.com/products/collaborative-science/biovia-draw/ctfile-no-fee.html. Below is a 

sample of a chemical structure record: (Figure 4-1) 
 

A Structure ID (optional) 

B Structure definition (the connection table) 

C Data for structure 

D Start of next structure 

 

http://accelrys.com/products/collaborative-science/biovia-draw/ctfile-no-fee.html
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Figure 4-1: Sample chemical structure connection table 
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SMILES Chemical Structure File 

The simplified molecular-input line-entry system (SMILES) is a specification in the form of a line notation for 

chemical structures using short ASCII strings. The SMILES chemical structure file should be formatted as a 

text spreadsheet file (such as CSV or TXT) including an ID column, the column containing the SMILES string, 

and any additional data columns. 
 

The following is a sample SMILES spreadsheet file. (Figure 4-2) 

 
 

Figure 4-2: Sample SMILES Spreadsheet File 

A Structure ID 

 

B The SMILES string column 

 

C ς D Additional data for the chemical structure 

 

Text Spreadsheet Data File 

A tabular file is a table of data values where there is one row per structure and one column for each data set. 

The first row defines the names of the data sets. The first column defines the structure ID. This file is usually a 

comma-separated file (CSV) or a tab-separated (TXT) file. Leadscope allows you to specify any delimiter you 

wish. These files are often created by exporting spreadsheet data from Microsoft Excel.  Here is an example of 

a tabular file using a comma delimiter: 
 

A First line names the data. LEU-CCRF-CEM and LEU-HL-60(TB) are the two data sets that are in 

this import file. Everything preceding the first delimiter is ignored (NSC in this example). 
 

B Each remaining row consists of a structure ID followed by a delimiter character and value for 

each data set. 

https://en.wikipedia.org/wiki/Line_notation
https://en.wikipedia.org/wiki/ASCII
https://en.wikipedia.org/wiki/String_(computer_science)
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Figure 4-3: Sample Text Spreadsheet Data File 
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Launching the Import Wizard 

To launch the Import Wizard, select Import Wizard from the Tools menu or from the Toolbar. The first 

screen you see is the “Welcome Screen” as shown below. (Figure 4-4) 
 

 

Figure 4-4: Import Wizard Welcome Screen 

 

Getting Started 

You import your file in two phases: 1) you examine your file; 2) you compare what you  will import with what  

is in the database. In the first phase, you review and edit your structure or data file, decide what to import, 

and calculate new data (e.g., create a new data set that is the log of a data set being imported). In the second 

phase, you select a database (the Personal database on your PC or the Enterprise database on the Leadscope 

Server) and examine how the new content will affect the database. 

 

There are six tasks in the first phase: 

 

1. Select a file to import. 

2. Describe the file format. 

3. Select the content (structures or data sets) to import. 

4. Edit your structure IDs. 

5. Edit data values. 

6. Calculate new data sets. 
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There are two tasks in the second phase: 

 

1. Compare your content with the database. 

2. Do a final review and start the import. 

 

The Import Wizard generates a page for each of these tasks. The title of the page includes the number of the 

task. You step forward and backward through these pages by clicking Next or Back. You can compare the 

new content against what is in the database without fear of inadvertently overwriting something on the 

database. 
 

Note: No changes will be made to the database at any time until you click Finish on the 
final page of the Wizard. 

 

 

On many of the Import Wizard pages you see a spreadsheet. The areas of the spreadsheet with a white 

background indicate cells which you can edit directly by clicking in the cell. In any context, you can always do 

the following: 

 

 toggle the display of a structure between a drawing and its ID (if you are importing from a 

chemical structure file) by clicking on the structure display button on the lower left of the 

spreadsheet, 

 

  sort the rows using a 3-level sort by clicking on the sort button on the lower left of the 

spreadsheet, 

 

  add or remove a numeric data set, 

  and add or remove a text data set. 

Each page is explained in more detail in the following sections. 

 

After correcting errors, it is often convenient to save the changed file. The Save As button below the 

spreadsheet on some pages lets you do this. This is handy when you would like to save the changes to a file 

without importing the changed file to the database. You can save the modified file as a chemical file (SDF or 

MOL) or as a tab-delimited text file. 
 

Step One - Select a File 

You begin the import process by selecting the file containing the content you want to import. Enter the name 

of the file you want or click Browse to initiate the File Chooser Dialog. In the File Chooser, find the file you want 

to import and click Open. Click Next to proceed. (Figure 4-5) 
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Figure 4-5: Select a file to import 

 

Step Two - Choose the File Format 

On this page, you describe the format of your file and review the first few entries to make sure you have the 

right file. (Figure 4-6) 
 

1. Select one of the three formats discussed in the section on preparing your files above using the 

“Select file format” dropdown pick list. (The Leadscope format is used by administrators who need 

to import Leadscope files. Ignore this option.) 

2. Select the format options that describe your file, such as the location of the structure identifier. 

a. If you are importing from a SD or MOL file, you may need to specify whether the structure ID 

appears on the first line of each chemical structure record and if not, what property contains 

the structure ID. 

b. If you are importing from a SMILES file, you will need to specify which field contains the 

structure ID and which field contains the SMILES string. 

c. If you are importing from a data file, you will only need to confirm the field containing the 

structure ID. 

 

NOTE: The Import Wizard limits chemical structure identifiers to 100 characters, any 
identifiers longer than 100 characters will be truncated with a tilde added to the end of the 
file to indicate the ID is truncated. 
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3. The Import Wizard displays a spreadsheet view of the first few entries (rows or records) of the file. 

You will be given an opportunity to make changes later in the process. 

 
 

Figure 4-6: Choose the File Format 

 

Step Three - Select the Content to Import 

On this page, you select the content you want the Import Wizard to import. 

 

1. Select the Structures checkbox to include all the structures in your file. 

2. By default, all the data sets in your file will be imported. The structures and data sets displayed in the 

spreadsheet will be imported. Clearing the checkbox next to any data set will remove it from the list 

and the spreadsheet. 

3. You can remove specific structures and the associated data from the content being imported. Select 

one or more rows and click Delete Selected Rows. 

 

Step Four - Select Data Types 

For each data column to import, it is required to specify the data type as either a numeric or text property. 

 

Step Five - Edit Structure IDs 

On this page, you can edit any structure IDs you wish to change. 
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1. If you are adding structures from an external source, they may have IDs that might match an ID in 

your database. You can make them unique by adding a prefix. To do this, enter the prefix in the text 

field and click Apply. 
 

2. To change specific structure IDs or IDs that match a pattern, click Find and Replace. The Find and 

Replace dialog prompts you for the pattern to find and a pattern to replace it with. 

3. As on the previous page, the structures and data sets you choose to import are displayed in the 

spreadsheet. 
 

Step Six - Edit Data 

On this page, you edit the data you want to change. 

 

1. To change specific values or values that match a pattern, click Find and Replace. The Find and 

Replace dialog prompts you for the pattern to find and a pattern to replace it. 
 

2. To rename a data set, first select it by clicking its column heading. Then click Rename Data Set. 

When the wizard displays the Rename Data Set dialog, enter the new name and click OK. 

 

3. As on the previous pages, the structures and data sets you choose to import are displayed in the 

spreadsheet. 
 

Step Seven - Select a Database 

In step seven, you can identify the target database to import your content and, optionally, assign the 

chemical structure set a label (Source ID) that can be used later as a search target. 

 

1. New content is imported into one of two databases: the Personal database located on your PC or 

the Enterprise database on the LSE Server. 
 

2. The Source ID is a label given to all of the chemical structures being imported. The Source ID is 

useful under normal operations of the Client as a constraint limiting a search query to a certain set of 

chemical structures. An administrator may also use the Source ID to identify structures to remove 

from the database using command line utilities provided on the Server. 
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Step Eight ς Review and Import 

This is the final page. When you click Finish, the import process begins and the database is permanently 

changed. 
 

1. The summary includes an overview of the structures and data sets to be loaded to the database, 

including the number of custom data sets you may have created in the property calculator and the 

number of new binning schemes defined. Review this to make sure it is what you expect. 

 

2. When the import completes, a project containing the chemical structures and data sets can be 

created for you. The default name of the project is the input filename. If you do not want to create a 

project deselect the checkbox. 
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Import Diagnostics 

As you advance from one page to the next, the Wizard runs diagnostics on the page just completed. If issues 

arise, the wizard generates an Alerts page as shown Figure 4-8. During the first phase, you see an ‘Alerts’ 

page if there are issues with your content; in the second phase, you see one if your content conflicts with the 

database. The ‘Alerts’ page contains a list of alerts. Each alert in the list contains a headline of the issue and a 

Resolve button. When you click Resolve, the Wizard displays an Alert dialog that guides you through your 

options for resolving the issue. 
 

Resolving Alerts and Conflicts 

All Alert dialogs have the following form: (Figure 4-7) 

 

1. The alert section restates the headline and provides a more detailed description of the issue. 

 

2. The action section consists of a list of actions you can take to resolve the issue. 

 

3. The help section illustrates the content that contains an error or conflicts with the database. It also 

provides interactive components to help you resolve the issue. 
 

 
Figure 4-7: Alert Example 
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During the first phase, the wizard checks for problems with the content in your file. Examples of two Alert 

dialogs are shown in Figure 4-8. 
 

The list of file alerts is as follows: 

1. Duplicate structure IDs. If more than one structure has the same ID, the duplicate records will be 

displayed as rows in the spreadsheet. To resolve this issue, either delete the duplicate structures or 

change the IDs so that all structures are uniquely identified. 
 

 

 

Figure 4-8: Duplicate Structure IDs and Non-Numeric Values Alerts 

2. Non-numeric values. All data must contain numeric values. If non-numeric values exist, they will be 

displayed in the spreadsheet as a row with three fields: the structure ID, the name of the data set, and 

the nonnumeric value in a red font. (See the bottom right dialog in the figure above.) To resolve the 

issue, you have two options. Delete the value by selecting one or more rows and clicking Delete Values. 

Alternatively, change the value by clicking Find and Replace Values or editing the cell directly. 
 

3. Incorrect structure records. Sometimes SDF files contain incorrectly formatted records that 

cannot be read. When the Wizard encounters badly formatted records, it skips them and begins again 

at the next good record it can find. It also generates an Alert which displays the line number of each 

record skipped. To resolve the issue, either exit the wizard and fix the file or ignore all structure 

records with errors. 

 

Conflict Alerts 

During the second phase, the Import Wizard checks for conflicts your content may have with the database. 

Sometimes alerts serve to remind you about possible outcomes to make sure you don’t take an action with 
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unintended consequences. For example, if your file has a data set with same name as one  on the database 

and both data sets have different values for some  of the same structures,  the values of the data set from 

your file could overwrite the values on the database for the structures in common. To be sure you are aware 

of this possible outcome, an alert is issued. Examples of two Alerts are shown in Figure 4-9. 

 

The conflict alerts are as follows: 

 

1. Duplicate data set names (see the top left Alert in the figure above). If your file has a data set with 

the same name as one on the database, you can resolve this issue in several ways. First, give the data 

set being imported a new name. Second, inform the Import Wizard that you really intend to update all 

the data sets on the database by clicking Change Data Sets. Third, you can choose to update only 

specific data sets from the list of data sets displayed in the help section. 
 

2. Data values cannot be binned (see the bottom right Alert in Figure 4-9). Every data set in the 

database is associated with a binning scheme. When updating an existing data set, the new values 

must be of the correct type (e.g. continuous or discrete numbers) and lie between the minimum and 

maximum values defined by the binning scheme. In Figure 4-9, some values from the data set in the 

file are above the maximum cutoff. These values are shown as the red histogram bar. The issue can 

be resolved in several ways. First, if you don’t need to update the data set on the database, just 

rename the data set. Second, you may simply want to ignore this data set until later -- don’t import it. 

Third, let the system automatically generate a new binning scheme for the data set being imported. 

Fourth, change the data set values that are not able to be binned by Leadscope. Finally, choose a 

different binning scheme that fits your data. 

 

3. Unknown structures. If a data set has values for a structure that has not yet been imported, an 

alert is issued. The connection table (atoms and bonds) read from an SDF file when a structure is 

imported is part of the structure’s definition and is used throughout LSE. You resolve this in two 

ways. 
 

a. If a prefix was added to the structure IDs when they were first imported, you will need to 

add that prefix to the IDs in your file. 
 

b. Delete the records (rows) for those structures not yet defined. 

 

4. Duplicate structures. You cannot redefine a structure that already exists in the database. The 

structures in the database on the Server are shared throughout the Enterprise and are copies of the 

structures in your corporate database. LSE administrators have access to utilities that allow them to 

update or delete these structures, but this is not generally available. You resolve this in three ways. 

1) You can import just the data associated with the duplicate structures, 2) You can give the 

duplicate structures from the file new IDs (by adding a prefix), 3) You can remove the duplicate 

structures and associated data from the content being imported. 
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Figure 4-фΥ 9ȄŀƳǇƭŜ ƻŦ ŀƴ ŀƭŜǊǘ ŘǳŜ ǘƻ ŀ ǇǊƻǇŜǊǘȅΩǎ Řŀǘŀ ǾŀƭǳŜǎ ƴƻǘ ŦƛǘǘƛƴƎ ƛƴ ǘƘŜ ŀǎǎƛƎƴŜŘ ōƛƴƴƛƴƎ 

scheme 
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CHAPTER 5 
 

 

 
 

The Project Browser 
 

 

Included in this chapter: 

 

¶ Overview 

¶ Navigating the Project Browser 

¶ Filtering and Constraining a Project 

¶ Applying Informatics 

¶ Exporting Results and Generating Reports 
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Overview 

A Leadscope project is a named collection of compounds, data and, optionally, user-defined hierarchy 

extensions. The project provides a virtual sandbox for data mining sets of chemicals against numerous 

endpoints using an interface called the Project Browser. The Project Browser allows you to interactively 

explore your chemical set and includes tools for slicing and dicing sets, drilling down to more detailed data, 

visualizing data, and advanced informatics tools. 
 

The core data mining component in the Project Browser is a pre-compiled chemical fragment feature 

hierarchy specific to the project chemical structures referred to as the Feature Hierarchy2. The hierarchy is 

constructed from a global set of over 27,000 chemical fragments specific to the small molecule, medicinal 

chemistry domain of chemistry. Each feature in the hierarchy represents a chemical substructure query 

hierarchically organized by chemical class. These are typically expensive queries that together would take a 

very long time to execute. Using the pre-compiled hierarchy in the Project Browser, the cost with generating 

these results has been eliminated and you can ask questions of your compound set unperturbed by having to 

regenerate query results. 
 

Projects can reside on the Leadscope Server (if you are using LSE or LSH) or on the desktop in the Personal 

database (if you are using LSE, LSH, or LSP). 

 

Navigating the Project Browser 

The Project Browser is divided into 4 main areas: a menu bar, a toolbar, a breadcrumb, and a spreadsheet 

pane. 
 

 

Figure 5-1: The Project Browser Overview 
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Menu Bar 

The menu bar categories are File, Edit, View, Tools, and Help. The File category includes options to open a 

new window, save the current project, showing detailed information for selected compounds, saving and 

opening informatics results, exporting components of the current project, and creating reports. (Figure 5-2) 

 
 

Figure 5-2: Project Menu Bar File Menu 

 

Save Options 

The options to save include Save Subproject As... and Save Similar As..., both of which will create new projects 

based on your input. The Save Subproject As... option saves the current subproject as a new project in the 

same folder as the parent project. The Save Similar As... option creates a new project using the chemical 

structures from the current project as structure similarity queries against a target project or database, in 

effect, performing a similarity buildup around each chemical structure in the current project or a selected 

subset. If you select this option, you should specify a name for the new project, whether to use a selected 

subset of chemical structures as the query seeds or to use the entire project, a cutoff value for the similarity 

percentage (the default value is 40%), and the target set of structures to perform the search against (for 

instance, the entire database, a group of selected projects, or a selected structure source) (Figure 5-3). 
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Figure 5-3: Options when creating a new similarity project 

 

Options for showing more detailed data 

There are several options for drilling down to more detailed data for a selected set of compounds, 

including: 

 

¶ Show Compounds – this option will open the selected compounds in a new browser tab in a 

Structures view with each compound in a cell 

¶ Show Compound Detail ς using this option you can view the Structure Detail view for a selected 

chemical structure 

¶ Show Studies ς this option allows you to display the Leadscope ToxML toxicity study data for a set of 

compounds in a spreadsheet view 

¶ Show Drug Info ς this option will retrieve the Leadscope ToxML known drugs data for a set of 

compounds 

 

Informatics results options 

There are options for opening and saving informatics results. You can open informatics results associated 

with the current project. 
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Export options 

The Project Browser includes several export options including to export the chemical structures to a structure 

file, numeric or text data to a spreadsheet file, the chemical structure fingerprints to a spreadsheet file, or to 

export the current view as a spreadsheet table to a spreadsheet file (Figure 5-4). 

 

 

Figure 5-4: Export options available in the Project Browser 

Exporting options include the following: 

 

¶ The Export Structures and Data option where you can export a selected structure set to a chemical 

structure file (SDF) with or without any associated data or you can choose to export only the data 

values to a text spreadsheet file. 

¶ The Export Fingerprints option allows you to export the underlying feature bit set for a set of 

structures in the project. 

¶ Using the Export Table option, you can export the current project view to a spreadsheet file 

(Microsoft Excel, CSV, or TXT). 

Reporting options 

The reporting options include Publish ReportΧ which will create a pre-configured report based on your 

location in the project browser or to tǊƛƴǘ ǘƻ t5CΧresulting in a PDF of the current project view. 

 

Toolbar 

The Project Browser toolbar is grouped by navigation, compound, informatics, visualization, and filtering 

actions. (Figure 5-5) 

 

 

Figure 5-5: An overview of the Project Browser Toolbar 
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¶ Navigation – The Backward and Forward buttons allow you to browse between open project pages. 

¶ Compound Actions – These actions allow you to drill-down into more detail for a selected group 

of compounds. The Compounds action will show the selected compounds in a structure grid view. 

The Studies action will show any available ToxML toxicity study data for the compounds. Similarly, 

the Drug Info button will show any available ToxML known drug data. The Subproject button will 

create a new project browser for a selected compound subset. 

¶ Informatics Tools – The informatics tools are used to apply statistical classification techniques to 

your set of compounds. 

¶ Visualization Tools – The visualization tools allow you to view your data set in a new molecular 

spreadsheet or structure grid tab using the Spreadsheet or Grid actions, respectively. You can also 

view data sets in either a scatter plot or histogram graph tab with the Graphs action. The current 

feature hierarchy can also be modified with the Features button, with actions to view the default 

Project Hierarchy, the Entire Feature Hierarchy including features that are not included in your set, a 

Feature Heat Map, a Constrained Hierarchy, or a Sorted Hierarchy. 

¶ Filter and Constraints – The filter and constraints tools are for dynamically removing your compound 

set. 

¶ Heat Map – The Heat Map tool constructs a heat map using the organization of the current view as 

the y-axis and selectable properties as the x-axis. 

 

Feature Hierarchy Pane 

The default project browser interface is the feature hierarchy pane displaying the Project Hierarchy. The 

Feature Hierarchy is the chemistry knowledge base used by many informatics methods in LSE and is a 

hallmark of Leadscope products. For each project, a bespoke chemical feature hierarchy is automatically 

created containing the reduced hierarchical organization of the chemical features that are present in the 

project compounds (Figure 5-6). 
 

 

 Figure 5-6: Feature hierarchy pane displaying the project hierarchy 
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The breadcrumb allows you to quickly navigate between open project windows in the order they were 

opened. Breadcrumbs are organized by the chemical set size with the intention of keeping track of 

increasingly reduced sets as you drill-down into your set of chemicals. So, each time you open a new subset 

of chemicals a new breadcrumb is created. For instance, in the following image (Figure 5-7) the project 

contains 2225 chemical records and a set of 4 records was opened. 
 

 

Figure 5-7: Project Browser Breadcrumb 

 

Clicking a breadcrumb will open the browser associated with the number of chemicals. Right-clicking a 

breadcrumb allows you to close the browser for that state without having to open it. 
 

Browsing the Project Hierarchy 

When you open the Project Browser, the first column The Feature Hierarchy is the chemistry knowledge base 

used by many informatics methods in LSE and is a hallmark of Leadscope products. It is discussed in more 

detail in Appendix 1. 
 

The Feature Hierarchy is a special type of column, in that it is organized in an interactive hierarchy and you 

can modify it based on several unique operations. These include the default Project Feature Hierarchy, the 

Entire Feature Hierarchy, a Constrained Hierarchy, and a Sorted Hierarchy. You can apply these visualizations 

to the Feature Hierarchy by selecting the Features button in the project toolbar such as in Figure 5-8. 
 

 

Figure 5-8: Features Visualization Options 

The project feature hierarchy represents an interactive organization of chemical fragment queries against 

your chemical set using the Leadscope global set of pre-defined, medicinal chemistry structure features (the 

Entire Feature Hierarchy) and pruned to only include those features with a match in your set. The initial view 

represents high-level chemical classes (such as Amino acids, Bases, nucleosides, Benzenes, etc.) (Figure 5-9). 
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Figure 5-9: The Project Hierarchy 

Each node in the hierarchy can be browsed by clicking the (+) button next to a folder. (Figure 5-10) 

 

 
 

Figure 5-10: The Project Hierarchy chemical feature classes 

Each feature can then, in turn, be examined in more detail by right-clicking the feature and selecting 

Definition ... (Figure 5-11) 
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Figure 5-11: Feature Details 

 

Figure 5-12 is an example definition for the alanine feature. 

 

 

Figure 5-12: Example feature definition for alanine 

By default, the feature hierarchy is accompanied by two columns: (1) a histogram bar representing the 

number of compounds matching this feature and (2) the frequency count. 
 

Adding Data to the interface 

The data-mining strength of the Project Browser is the ability to be able to leverage the chemical information 

of the project feature hierarchy by adding columns of data to the spreadsheet. These columns can be 
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operations performed on numeric properties, descriptive properties (such as name), miniature graphs, 

Leadscope calculated properties, etc. 
 

To add data to the spreadsheet you can click the Columns button in the toolbar or right-click any column 

header and choose Add/Remove Columns (Figure 5-13). 
 

 

Figure 5-13: Right-Click to Add/Remove Columns 
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This will launch the Add/Remove Columns interface. (Figure 5-14) 
 

 

 
 

 

Available 

Column 

Types 

Figure 5-14: Add/Remove Columns Interface 
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There are numerous column types available to be added to the Project Browser. These include the following 

high-level columns: 

 

Structure The chemical structure image 

Name The name column is available for Leadscope content and is 
the primary 
chemical name for the substance as defined in the 
associated ToxML record for the compound. 

Structure The structure column allows you to add an image of the 
chemical 

structure to a spreadsheet view. 

Total 
Frequency 

The total frequency is the total of the number of substances 
in a row or 

associated with a feature. 

Histogram 
colored by z- 

score 

This column is a frequency histogram that is then colored 
based on the 

Z-Score of a selected data set using the Z-Score color 
scheme. 

 

 

Statistics for SAR 

 

There are also columns available that are typically used in performing a chemical structure activity 

relationship (SAR) analysis, including the following: 

 

Frequency 
with value 

This column is the number of structures in a 
row. 

Mean This is the mean of a selected data set for the 
sample set. 

Z-Score The Z-Score is a measure of how many standard deviations 
the sample 

mean is above or below the population mean. 

Abs Z-
Score 

The total frequency is the total of the number of substances 
in a row or 

associated with a feature. 

Chi-
Square 

This column is a frequency histogram that is then colored 
based on the 

Z-Score of a selected data set using the Z-Score color 
scheme. 

T2-Test This statistic is the significance measure, Hotelling’s T 
squared statistic. 

http://www.statisticshowto.com/mean/
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Abs T2-
Test 

This is the absolute value of the T squared statistic. 

 
 

Feature Descriptors 

 

Molecular 
Weight 

This is the substance molecular weight. 

Atom 
Count 

The number of atoms in the chemical. 

Formula If the chemical is from a Leadscope content module source, 
it will have 

the molecular formula. 
 

Summary Statistics 

 

Median The median property value for the sample set. 

Std 
Deviatio
n 

The standard deviation of the sample set for a selected 
numeric property. 

Min The minimum value of a selected numeric property for the 
sample set. 

Max The maximum value of a selected numeric property for the 
sample set. 

Range The range of values (from min to max) of a selected numeric 
property for 

the sample set. 
 

Binary Data Statistics 

 

The following statistics are intended to be used when you are comparing predicted to experimental binary 

values. 

 

Sensitivity The true positives divided by the sum of the true positives 
and false 
negatives. 

Specificity The number of true negatives divided by the sum of the true 
negatives 

and false positives. 

Negative 
Predictive 
Value 

The number of true negatives divided by the total number of 
negative 

results (true negatives plus false negatives). 
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Ratio of 
Inactives 

The active to inactive ratio of a binary set. 

Precision The accuracy of the predicted value when compared to the 
experimental value. 

 

Comparative Statistics 

 

The following statistics are meant to compare to data sets. 

 

Ratio of 
Means 

The ratio of the means of two sets. 

Difference of 
Z-Scores 

The difference between two numeric properties’ Z-Scores 
for a given 

sample. 
 

Graphs or Charts 

 

Frequency 
Histogram 

A histogram bar indicating the frequency of a sample 
set by its size. 

Miniature 
Distribution 

A miniature distribution of the selected data for a 
sample set. 

 

Cluster Stats 

 

Cluster stats apply to clustering informatics results. 

 

Internal 
Distance 

The internal distance is the mean internal distance for 
each cluster 

commonly referred to as the inter-cluster distance. 

Quality 
Index 

The quality index only applies to K-Means Clustering 
results and based 

on the Davis-Bouldin quality metric1. 

 

Modifying a Column 

Any column can be modified to change the color of the column (if you wish to create color-correlated cells) or 

the width of the column. To modify a column, you can select one of the modification buttons from the 

Add/Remove Columns dialog or if you wish to only modify the cell width right-click a column and choose 

Column Properties (Figure 5-14). 
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Figure 5-14: Column Settings 

 

Filtering and Constraining 

To the right of the Overview pane is the Filters pane. Filters are used to dynamically remove structures from 

subsets of structures according to ranges of data. To add the filter pane to a Project Browser, click the 

Click Choose in the Filter pane’s title bar to display a window containing a list of data sets to use as filters. If 

folders were not used to organize the data sets, then select each filter you want to add. If folders were used 

to organize the data, selecting a folder will include all the data sets within the folder as filters. 
 

Filters can be applied to a project at any time and are used throughout the three overview tabs (Histogram, 

Scatterplot, and Feature). You can use the filters to prune the data by choosing ranges of values in the data 

set they represent. By default, eight filters are calculated by LSE for each structure imported into its 

database: Molecular Weight, Parent Molecular Weight, Number of Rotatable Bonds, Number of Hydrogen 

Bond Acceptors, Number of Hydrogen Bond Donors, Polar Surface Area, ALogP, and Lipinski score. Filters are 

created for any imported data set that is associated with the project and can be applied to the project using 

the Filters button in the toolbar. (Figure 5-15) 



77 Leadscope Client User Guide – Version 3.8 

Proprietary and Confidential 

 

Proprietary and Confidential 

 

 

 

 

 

Figure 5-15: Select properties to use as filters 
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Informatics Tools 

Clustering 

Clustering1 is a bottom-up classification tool used to identify groups (clusters) of similar observations. 

Clustering can be done by similarities based on biological profiles, activities, or physical properties or by 

structural features. Similarities of observations can be estimated by Euclidean distance (for biological and 

property profiles) or by Tanimoto distance when clustering based on chemical feature. Clustering can be 

initiated from the Project Browser by selecting Generate clusters ... in the Tools menu, or clicking the 

Clusters button on the toolbar. This will bring up the dialog shown in Figure 5-16. 
 

 

Figure 5-16: Clustering dialog 

If a set of compounds was selected, you have the option of performing the analysis on the full project or only 

the selected set. The edit box labeled Name will be used to store the analysis results if you choose to save 

them. You may want to change this to a more meaningful name. If you selected a subset such as a structural 
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feature from the feature hierarchy then the default is to cluster only the selected subset. Otherwise, the 

entire project is clustered (except those compounds eliminated by any filter settings). The default 

parameter settings cluster compounds by structure features using the average linkage method with a 

threshold of 0.7. This generally produces clusters with a high degree of structural similarity and is a good 

place to start. 
 

Clustering results are first displayed in a spreadsheet view sorted in decreasing order by frequency. Three 

other views of the clustering results are provided: a spreadsheet view, a structure review format, and a tree 

view. You can switch between views by selecting the desired tab to the upper-left of the display window. 

The structure review format is illustrated in Figure 5-16. For convenience all singletons (that is a cluster 

containing only one item) are placed together in a cluster labeled “singletons.” This behavior is optional and 

can be turned off on the Clustering Parameters Dialog (Figure 5-15, click the Advanced ... button). 

 

 

Figure 5-17: The default presentation of cluster results is the structure review where each clusteǊΩǎ ǊŜǇǊŜǎŜƴǘŀǘƛǾŜ 
structure is displayed. The clusters are identified by cluster number and the ID of the cluster representative. 

Leadscope provides three general methods for clustering: (1) hierarchical clustering by agglomerative 

nesting, (2) K-means clustering a non-hierarchical method, and (3) Jarvis-Patrick clustering also a non- 

hierarchical method. 

 

Hierarchical Clustering 
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Agglomerative nesting starts with each compound in a separate cluster and then proceeds in an iterative 

fashion merging the closest pair of clusters. There are several ways to determine the distance between two 

clusters, and this gives rise to different flavors of agglomerative nesting. Leadscope provides four methods: 

 

1. Average linkage 

2. Single linkage (nearest neighbor) 

3. Complete linkage (furthest neighbor) 

4. Ward’s minimum variance method 

 

Clustering observations larger than several thousand compounds are usually prohibitive due to performance. 

However, Leadscope handles large data sets well. 

 

Average Linkage. A pair consists of two observations, one from each cluster. The distance between two 

clusters is defined to be the average distance between all pairs in the two clusters. You can set the maximum 

average distance by selecting Cluster threshold distance (Figure 5-17) and entering a value. This method 

tends to join clusters with small variances and is slightly biased toward producing clusters with the same 

variance.2   Average linkage method is one of the better methods for structure clustering and is recommended. 
 

Complete Linkage (Furthest Neighbor). The distance between two clusters is defined to be the maximum 

distance between an observation in one cluster and an observation in the other cluster. You can set this 

distance by selecting Cluster threshold distance (Figure 5-18). This method is biased toward producing 

clusters that divide the space approximately equally and can be distorted by moderate outliers3. 

 

Single Linkage (Nearest Neighbor). The distance between two clusters is defined to be the minimum 

distance between an observation in one cluster and an observation in the other cluster. You can set the 

maximum of this distance by selecting Cluster threshold distance (Figure 5-17) and setting a value. This 

method has the ability to detect elongated and irregular clusters. Single linkage tends to chop off the tails of 

distributions before separating the main clusters.3 
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Figure 5-18: Clustering advanced settings 

 

Non-Hierarchical Clustering 

Leadscope provides two methods for non-hierarchical clustering: (1) Jarvis-Patrick5 and (2) K-means. 

 

Jarvis-Patrick.  In this method the k-nearest neighbors of each compound are determined using the Tanimoto 

similarity coefficient (TC). Two compounds will be in the same cluster if: (1) they are in each other’s k-nearest 

neighbor list, and (2) they have j < k nearest neighbor in common.  You can set parameters j and k in the 

dialog shown in Fig. 17.11. In addition, you can set the maximum neighbor distance (1-TC) for compounds to be 

included in the k-nearest neighbor list. Because it does not require calculating an n x n similarity matrix, the 

Jarvis-Patrick method can be used to cluster very large sets. However, it is biased toward producing a few 

large clusters and many singletons. 
 

K-Means Clustering. K-means is a non-hierarchical clustering method. It proceeds by performing an iterative 

alternating fitting process to form the specified number clusters. It first selects a set of n points (the cluster 
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seeds) as an initial guess of the means of the clusters. Each observation is assigned to the nearest seed to 

form a set of temporary clusters. The seeds are then replaced by the cluster means, and the process 

continues until no further changes occur in the clusters. The K-means method is intended for use with larger 

data tables, up to approximately 100,000 observations. 

 

Cluster Representative 

The cluster representative is chosen using one of two methods: (1) representative compound and (2) 

signature. 
 

Representative Compound. For the default cluster description method – representative compound, the 

“center-most” compound is chosen to represent the cluster. This is the compound with the smallest 

maximum pairwise distance to all other compounds in the cluster. This method allows for the best 

performance and is recommended when grouping sets greater than 1000 compounds. 
 

Signature. The signature option for cluster representation employs the Macrostructure Assembly (MSA) 
method, where the constituent structural fragments of the cluster members are re-assembled to create 
larger substructures that discriminate for membership in the set2. While this approach is more 
computationally expensive, the result is a set of new, descriptive features that could be used to describe the 
set of compounds. 

Scaffold Generation 

This process reassembles structural fragments in a directed way to produce larger substructures that are 

commonly occurring within a group of compounds or that discriminate for a biological response within the 

group. 
 

There are three types of scaffolds that can be generated (Figure 5-19). 

 

1. Scaffolds for R-Group Analysis. Use this option to generate candidate scaffolds for R-group analysis for a 

congeneric series. This choice will result in large sub- structures that are commonly occurring within the 

project or selected set of compounds. 
 

2. Predictive Features. This will result in features that discriminate for a biological response within the 

project or selected set of compounds. If you choose this option, you must also select a data field that Lead- 

scope will use to optimize the generated structural features. 
 

3. Scaffolds for Classification. Use this option to generate scaffolds to identify large structure classes within a 

heterogeneous set of compounds. This choice will result in large substructures that occur in at least 10 

compounds. 
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Figure5-19: Scaffold generation options 
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Select the desired scaffold type and click Next. An example of a scaffold result (shown in the default cluster 

spreadsheet) is displayed in Figure 5-20. 

 

 

Figure 5-20: Example scaffold result in the default structure view. 
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R-Group Analysis 

R-Group analysis provides a convenient way to study the effects of positional and substituent variations on 

biological activity within a congeneric series. The analysis requires a set of compounds and a common 

substructure or scaffold. Lead- scope identifies the scaffold in each compound, the positions of variability (R- 

groups), catalogs the substituents at each position and presents the initial results in a spreadsheet view. 
 

The user can then create a series of summary views by selecting combinations of R-groups on the scaffold. 

 

Step One. Select a set of compounds to analyze in the Project Browser. 

 

Step Two. Select a scaffold for r-group decoration (Figure 5-21). If you have a scaffold you want to use, you 

can paste it from a drawing program or browse to it as a MOL file. Otherwise the wizard will automatically 

generate a scaffold. 
 

 

Figure 5-21: Specify a scaffold 

Step Three. Select Datasets to View. This allows you to add data columns to the R-group table. Navigate to 

the desired data folder, select one or more datasets then click Next. 

 

Step Four. Select Name. Enter a name which will be used to store analysis results and then click Finish. The 

initial results are shown in Figure 5-22. 
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Figure 5-22: Initial Scaffold Results 

The structure diagrams for substituents contain an R that indicates the point of attachment on the scaffold. 

The substituent spreadsheet can be re-constructed based on substitution pattern such as shown in Figure 5- 

23 by clicking Change Substitution Points and then selecting specific combinations of R-groups to combine 

on the scaffold. 
 

 

Figure 5-23: Specify substitution points on the scaffold 
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CHAPTER 6 
 

 

 

 

Searching 
 

 

Included in this chapter: 

 

¶ Overview 

¶ The Search View 

¶ Search by Structure 

¶ Modify a Search Query 

¶ View Search Results 

¶ View Compound Details 

 

Overview 

Leadscope builds and maintains a series of toxicity databases ranging from general toxicity (the Leadscope 

Toxicity Database), to study type specific databases with calculated compound-level call data (the SAR 

databases), to smaller source specific study type databases from regulatory agencies (the regulatory 

databases). 
 

The Leadscope Toxicity Database is comprised of chemical structures and toxicity study data from the 

National Institute for Occupational Safety and Health (NIOSH) Registry of Toxic Effects of Chemical 

Substances (RTECS), the Environmental Protection Agency (EPA) Distributed Structure-Searchable Toxicity 

Database (DSSTox), the National Institute of Environmental Health Sciences (NIEHS) National Toxicity 

Program (NTP) chronic studies and data from the Master Table Skin Sensitization data set. Together, these 

sources cover acute, multiple dose studies including sub-chronic liver toxicity, carcinogenicity, genetic 

toxicity, reproductive, and irritation endpoints. 
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Leadscope offers two refined SAR databases for carcinogenicity and genetic toxicity. These products provide 

test chemical endpoint calls with a high level of reliability and confidence. They contain validated chemical 

structures where a SAR-form of the chemical has been derived (removing salts, charges, etc.) from the 

chemical’s parent form and merged with a calculated endpoint call derived from underlying study data. The 

SAR Genetox Database contains the original (parent) compound records along with derived SAR records and 

genetox ToxML study data from FDA CDER NDA (New Drug Approval), FDA CFSAN FCN (Food Contact 

Notification), NIH NIEHS NTP, CCRIS, and other primary data sources. The SAR Carcinogenicity Database 

includes the parent and SAR forms of the chemical records with carcinogenicity data from FDA CDER NDA 

(new drug application), FDA CFSAN FCN (food contact notification), NIH NIEHS NTP, CCRIS, EPA DSSTox CPDB 

and other primary data sources. 
 

The Regulatory Databases include study type specific data covering acute toxicity, genetic toxicity, 

chronic/sub-chronic toxicity, and reproductive/developmental toxicity from the FDA CFSAN and CDER sources 

along with the Marketed Drugs Database. 
 

In the Leadscope databases there generally are three types of data – the chemical compound record, text 

and numeric data linked to the chemical compound record, and ToxML study data associated with the 

chemical compound. 
 

ToxML is a richly-defined ontology including toxicity-based fields and controlled vocabulary that covers 

numerous toxicity endpoints (or study types) curated in the extensible markup language (XML). The goals of 

this publicly available schema are to capture and standardize toxicity data down to the dose-treatment level 

while providing aggregated summary calls at the study and compound levels. Owing to the depth of the data 

recorded in this format, end users can perform a range of tasks spanning the retrieval of experimental results 

to incorporated aggregated calls in a data mining or predictive modeling role. In general, the ToxML schema 

partitions toxicity study data into compound, study, test, and treatment levels. This relationship creates a 

linkage across the chemical structure, aggregated endpoints for inclusion in a predictive model, and detailed, 

experimental results. 
 

The toxicity databases represent numerous, disparate toxicity study sources that have been normalized and 

then transformed based on the ToxML schema. This approach allows multiple study types to be seamlessly 

merged for each compound record. In addition, the chemical structure records are validated and then 

verified as unique. This concurrent record linkage of the compounds and toxicity studies, their 

transformation to a rigorous domain-specific ontology, and continuous quality review ensure that the 

previously disparate study sources can be accessed in a consistent and repeatable manner.  Consequently, 

the experimental toxicologist is empowered to search, retrieve, and review compound records based on 

specific dose-treatment data while the computational toxicologist is able to to extract and transform this 

data to a summary response to train predictive models. 
 

The Leadscope search tool, referred to as the Search View in the Leadscope client, allows users to query the 

Leadscope toxicity databases using several query types including chemical structure queries (e.g. exact, 

substructure, and similarity searches), toxicity study queries using query forms constructed from the ToxML 
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schema, an assortment of names and ids (e.g., chemical name, trade name, Leadscope ID, or CAS registry 

number), text and numeric endpoint properties (e.g., SAR database toxicity calls, endpoint values, chemical 

calculated properties), and source. The search tool also provides a query editor where different search 

elements (e.g., combining chemical similarity structure search with specific toxicity study terms) can be 

combined into a single query. There is also a complete set of visualization, exporting, and reporting options 

for investigating the search results. 

 

The intent of this chapter is to familiarize users with the Search View interface by providing a functional 

overview of the interface, demonstrating example search queries, and covering options for reviewing and 

exporting search results. 
 

Search Overview 

The Search View is the search and retrieval interface in the Leadscope client. It is comprised of four main 

areas: a toolbar, the search type section, the search form section, and the search query editor (Figure 6-1). 
 

 

Figure 6-1: Leadscope search view overview 

The toolbar includes options for reviewing search results including: 

 



91 Leadscope Client User Guide – Version 3.8 

Proprietary and Confidential 

 

Proprietary and Confidential 

 

 

 

¶ New Project – used to build a project based on your search results 

¶ New Query – create a new query 

¶ Refine Query – alter your existing query 

¶ Structures – view selected chemical structures in a separate window 

¶ Related Structures – view structures that are related to the selected structure 

¶ Remove – remove the selected chemicals from the results 

¶ Display Studies – create a table organized by study for selected chemicals 

¶ Display Known Drug Information – create a table organized by marketed drug information for 

selected chemicals 
 

The search type section is a hierarchically organized browser of the available search forms. This section 

includes the following groups of search forms: 
 

¶ by name – this includes search entry forms for compound id (the Leadscope Registry id), CAS id, 

InChI, any name, and molecular formula 

¶ by structure ς here you can select to search using chemical structure queries, the types of queries 

include exact, family, similar, and substructure 

¶ by dataset values ς this group includes numeric and text property datasets 

¶ by genetox study types ς here you will find numerous genetox search forms (such as bacterial 

mutagenesis) 

¶ by in vivo repeated dose study types ς these include several chronic, sub-chronic and 
carcinogenicity search forms 

¶ by in vivo single dose study types – here you will find the acute toxicity search form 

¶ by skin sensitization study types – this section includes the local lymph node assay study search 

form 

¶ by known drug information – this section contains search forms relating to the Leadscope 
Marketed 
Drugs Database content module and includes search forms for therapeutic categories, drug product, 

and Physician’s Desk Reference (PDR) reference 

¶ by dataset values – this section includes search forms for numeric and text properties (either 

provided as Leadscope content or your own data) 

¶ by collection – here you can limit your source to a library (source id) or a Leadscope project 

¶ other – this section includes a form named 'text' where you can enter wildcard searches that are not 

included in any of the other search forms 

 

The search form section contains the specific search options for each search type, allowing more detailed 

selection or entry of the search elements. For example, browsing to the by genetox study type -> bacterial 

mutagenesis search form will present several terms specific to bacterial mutagenesis organized by study 

information including the study source or study identifiers along with test information including the test 

system, test conditions, and test results (Figure 6-2). Each of these terms can be individually selected and 

included in the search query. 
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Figure 6-2: Example search form terms for bacterial mutagenesis 

The Search View allows complex search queries to be assembled and refined with the search query editor. 

Several edited search forms can be combined in the query editor and are represented as new rows in either 

the Search For or Limit By fields. Between each of these rows an operator can be selected specifying the logic 

to combine the entries in the editor. There is no limit to the number or type of search elements that can be 

included in the query editor. 
 

Each search form is added to the editor as either a Search For or Limit By element (Figure 6-3). Specifying a 

query element as Search For adds it to the set of query targets, while the Limit By element constrains the 

query results. This distinction allows a Limit By query element to be distributed across multiple Search For 

elements (following the distributive law). For instance, to retrieve chemical structures similar to a query 

substance that contain data in one of several different study types, each study type would be added to the 

query editor using the Search For operation and the structure similarity query would be added with the Limit 

By operation, effectively applying parentheses around the query elements in the Search For field and 

distributing the Limit By query to them as shown in Equation 1. 



93 Leadscope Client User Guide – Version 3.8 

Proprietary and Confidential 

 

Proprietary and Confidential 

 

 

 

 
 

Figure 6-3: Search query editor operations 

 

Limit By AND (Search For AND Search For AND Search For)  

 

 

Equation 1 

Each time a search element is added to the query editor using either the Search For or Limit By operations; it 

will be added to the query editor as a new row in the appropriate section with a choice of operator defining 

how the element relates to the previous row (Figure 4). 
 

 

Figure 6-4: Search query editor operators 

The choices for this operator are listed below. 

 

¶ AND – this will search for compounds containing both query elements 

¶ And in study ς this will search for both query elements occurring in the same study 

¶ OR ς this will search for either query 

¶ Or in study ς this will search for either query in the same study 

¶ MINUS ς this will find all of the results from the first query minus any that occur in the second query 

 

For example, in Figure 6-5 two search form elements in the genetox study types->bacterial mutagenesis study 

type – the NTP source and Salmonella typhimurium species were added to the search query editor with the 

Search For operation as separate rows allowing for the selection of an operator between in each row, in this 

case And in Study. A structure similarity (40% similar to Acetylsalicylic acid) query was then added to the 

query with the Limit By operation (Equation 6-2). 
 

 

Figure 6-5: Search query editor example 
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40% similar to  Acetylsalicylic acid AND (having a bacterial mutagenesis 

study from NTP AND IN THE SAME STUDY with test results for Salmone lla 

typhimurium )  

 

 

Equation 2 

When the query has been constructed it can be executed by clicking the Search button. To modify the query, 

the elements can be modified  by clicking  the Edit button at the end of the query row, and then updated 

in the search form section by clicking the Update Query button.  A query row can also be deleted by clicking 

the Delete button at the end of the row. 

 

Searching by compound name or ID 

The Search View allows searching by the registered compound ID (the Leadscope, or LS-, ID), CAS registration 

number, name, or other ID. This example illustrates how to perform a basic search using the compound name. 

 

Example 1A: Search by Compound Name 

This example will illustrate how to search across the toxicity databases for compounds containing the name 

naproxen. 

 

1. To perform a query by chemical name, select the by name search type in the Search View. 

2. There are several choices to search by name shown as links in Figure 6-6. 
 

 

Figure 6-6: Search by name 

The choices include: 

 

¶ compound id – the unique identifier used when the chemical was loaded into Leadscope 

¶ CAS – the Chemical Abstract Service (CAS) registration number 

¶ other id – this will search the Beilstein Handbook ID, EC-Number, DSSTox RID, DSSToxSID, DSSTox 

CID, or NIEHS NTP ID 

¶ any id – search against any of the IDs 
¶ name – this will search for chemical names, trade names, and synonyms 

¶ InChI – this will search the InChI 

¶ molecular formula – this will search the molecular formula of a query chemical 

 

3. Select the name link to open the corresponding search form. 
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4. In the search form enter the compound name naproxen such as in Figure 6-7. 

 
 

Figure 6-7: Enter naproxen in name search form 
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6. Click the Search button at the bottom of the page to execute the query. 

 

The results will be returned in a Structure table with each compound record that contains the name 

naproxen 

in a grid view (Figure 6-8). 
 

 

Figure 6-8: Naproxen search results 
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Searching by toxicity study details and findings 

The search form section includes the search fields and terms for each of the study types. In the case of the 

toxicity study search forms, they are organized by study information including source and identifiers along 

with test information including test system, test condition, and test results (study calls are included under the 

test results). Multiple selections can be made in a search form and each element will be combined into the 

same line of the query editor with an “OR” statement. In this manner, the search form selections can be 

combined with other types of searches, such as by chemical structure (as described in the Search Overview 

section above). A very common practice is to perform a search based on chemical similarity combined with 

toxicity study data. This is often referred to as analog searching and used in read-across analysis. 
 

Chemical similarity searching in Leadscope, compares two compounds based on the Leadscope set of 

chemical features (greater than 27,000 chemical fragments). This pair-wise comparison is performed using a 

Tanimoto coefficient – a ratio of the chemical fragments in common by the total fragments between two 

chemicals. 

 

Example 1B: Search by toxicity study data 

In this example, the toxicity databases will be searched for compound records containing bacterial 

mutagenesis results from the NTP source that are chemically similar to the compound caffeine. 

 

1. Open the structure similarity search form by clicking by structure ->similarity in the search types 
section and click browse in the search form to select the caffeine MOL file and click Search For to add 
this form with the default search parameters to the query (Figure 6-9). 

 

 

Figure 6-9: Similarity search for caffeine 
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2. To add the bacterial mutagenesis study type, open the genetox study types -> bacterial mutagenesis 

form. 

 

3. The first search field in the bacterial mutagenesis form is the source field, select the “ntp” term, then 

click the Search For button to add this form to the query (Figure 6-10). 

 

 

 

Figure 6-10: Search bacterial mutagenesis studies by the NTP source 

 

 

4. Now, click the Search button at the bottom of the Search View page to execute the query. 

5. The results will be displayed as a series of chemical compounds in a grid view with the percent 

similar reported in the upper-left corner of each record (Figure 6-11). 
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Figure 6-11: Search results - records similar to caffeine with bacterial mutagenesis study data from the NTP 

 

Search Results 

Search results in Leadscope are presented by default as the chemical compound records matching the query. 

These results organized by chemical compound can be viewed in a structure grid, spreadsheet, or graph 

visualization. Alternatively, the search results can be viewed using toxicity study data as the key rather than 

chemical compound record. 

 

Viewing and extracting study summary data 

The default search result visualization is the Structures view, where the compound records that match the 

search criteria are displayed in a grid. There are three visualization tabs for examining search results: 
 

¶ Structures – this is the default view, displaying each of the search result chemicals as individual cells 

¶ Spreadsheet – this tab displays the search results in a molecular spreadsheet, here you can add 
additional text or numeric property values, toggle the display of the chemical structures, sort by 
columns of data, and display chemical names and IDs; The molecular spreadsheet view is the most 
frequently accessed of the views and affords the most flexibility 

¶ Graphs – here you can view the search results in either histogram or scatterplot graphs plotted 

against numeric properties 
 

The ToxML study results can be displayed for each compound record by selecting the record and double- 

clicking. While this is useful for drilling down into the individual compound record, it may also be desirable to 
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view aggregated data from the underlying toxicity studies in the spreadsheet, consequently any numeric  or 

text data associated with the search result compounds can be added to the molecular spreadsheet or 

included as endpoints in the graphs view. However, the utility of this visualization is limited to only 

compound-level summary endpoints. Therefore, there is an option to Display Studies for the search results, 

populating the Study Summary Table with a view pivoted at the ToxML study level. In this view, the chemical 

compound records are repeated for each study entry. 
 

The results can be exported in a number of ways for all of the results or a selected subset. The high-level 

information in the search result spreadsheet can be exported to a chemical structure file with or without data 

associated with the structures, without the chemical structure to a text or Microsoft Excel spreadsheet file, as 

the Leadscope chemical fingerprint of the structures, or the current molecular spreadsheet itself to a text or 

Excel spreadsheet. The results can also be printed to a PDF file or included in a pre-formatted report. The 

detailed search results can be exported in a similar fashion using the Export Table, Print PDF, or Publish Report 

options in the Study Summary Table toolbar. 

 

Example  2A:  View study summary  data 

To view study data in the spreadsheet view, there are two options depending on the level of data to be 

presented. For high level data, such as high-level compound calls, chemical name, or identifier, the user can 

choose to Add/Remove Columns to the search result spreadsheet. If the desired level is to display more 

detailed study data, test results, or treatment data in the spreadsheet then the Display Studies function 

 is available in the Search View toolbar. 

To add high-level ToxML data or numeric/text properties to the spreadsheet, users can select the 

Spreadsheet tab and then right-click the Structure column header and select Add/Remove Columns. This will 

open the Add/Remove Columns interface where it is possible to select a column type (such as IDs, numeric 

data, etc.) and add them to the spreadsheet by clicking the Add Column button. For example, the Chemical 

Name column and a Numeric Dataset could be added to the spreadsheet (Figure 6-8). 
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Figure 6-8: Add/Remove Columns 
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To add detailed ToxML study data to the spreadsheet, click the Studies button in the toolbar opening the 

Study Summary Table in a new window. The default view is to pivot the study data at the Study level of the 

underlying ToxML data, each compound record will be repeated for each study type and include the chemical 

structure, the CAS Number, study type, study call, test calls, species, references, and source columns (Figure 6-

9). 
 

 

Figure 6-9: Study Summary Table 

For this example, to identify the Bacterial Mutagenesis test results for these structures, sort the Study Type 

column by clicking it (Figure 6-10). 
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Figure 6-10: Sorted Study Summary Table 

In these results, the test details (Test Calls, Species) with counts in parentheses will be shown as a list in the 

cell. For example, the NTP study (report number 543950) for the chemical LS-566 includes the test calls 

Negative(20), Equivocal (2) indicating the study has 20 test results reported as negative and 2 test results 

reported as equivocal. 

 

Example 2B: Exporting study data 

This example will detail options users have to export high-level search results and detailed study data. The 

high-level results can be exported as an SDF file, a text spreadsheet file, a molecular spreadsheet file, as the 

Leadscope chemical fingerprint, or to a report using the File -> Export options (Figure 6-11). 
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Figure 6-11: File -> Export options 

Users can create a report of the search results using File -> Publish Report in either RTF or PDF format. 

 

In a similar fashion, the detailed study information can be exported from the Study Summary Table. In this 

case, the options are included in the toolbar but are essentially the same – Export Table, Print PDF, or Create 

Report (Figure 6-12). 

 

 

Figure 6-12: Study Summary Table export and report options 

In Example 2A, the search results with Bacterial Mutagenesis study type records were identified. Using that 

selection, the results can be exported to a Microsoft Excel spreadsheet file (Figure 6-13). 
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Figure 6-13: Exported Study Summary Table results 

 

Accessing the full study information 

For a more detailed review of the ToxML study data available for an individual compound, the data is 

available in a drill-down fashion by simply double-clicking the compound opening a new Compound Details 

window. 

 

Example 2C: Full study details 

In this example, the full study details for a specific compound with the Leadscope ID LS-124738 are retrieved. 

Double-clicking the search result record for LS-124738 will open the Compound Details window. Here the 

structure image, along with a Compound tab containing IDs, names, and associated compound links and each 

of the study types with associated ToxML data are presented. In the case of LS-124738, there are tabs for the 

Compound information, and Genetox, Carcinogenicity, Chronic/Subchronic, Acute Toxicity, Multiple Dose, 

Tumorigenic, Reproductive/Developmental, and Ecotoxicity toxicity study types (Figure 6-14). 
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Figure 6-14: Compound Details for LS-124738 

The toxicity study type tabs will contain high-level numeric and text properties for the compound record from 

relevant endpoints along with a study table providing high-level summary data for each study. For instance, 

opening the Genetox tab for the LS-124738 record will show the high-level data available from the SAR 

Genetox Database for the compound followed by a spreadsheet of the numerous study records (Figure 6-15). 
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Figure 6-15: Genetox study data available for LS-124738 

Each of the studies can be displayed in a Tree View showing the ToxML organization of the study by double- 

clicking the row or selecting the row and choosing the Details button. For this example, selecting the first 

study on the list in Figure 16 – the CCRIS study from “Kadotani, et al (1984)”, will open the details captured 

for that study in the Tree View (Figure 6-16). 
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Figure 6-16: ToxML Tree View 

The ToxML tree is organized generally by study, test, and treatment levels. In Figure 6-16, the study level 

contains the study type, study calls, study report number, and references. The test level contains test system 

details such as species, strain, metabolic activation; test conditions such as solvent  vehicle,  experiment  id, 

test id, and assay technique; along with negative and positive test control information such as the control 

compound name, and the treatment results for the control. The treatment level contains each of the doses 

and the treatment results including the any comments, precipitation, cytotoxicity, and treatment-related 

outcomes or effects. 
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CHAPTER 7 
 

 

 
 

Read Across 
 

 

Overview 

Read across is a data gap filling approach for predicting a chemical’s biological response where the structure 
is known but the necessary endpoint data is not. In this exercise, endpoint data is read across from a source 
chemical to the target substance based on the two being similar in some fashion, commonly chemical 
structure similarity. 
 

There are two predominate read across techniques – analog and category. The analog approach is typically 

based on 1 – 2 source compounds with a high degree of similarity to the target substance. Using this 

approach, the biological response from the analogs is directly read across to the target. The category 

approach is normally performed on a slightly larger set of compounds selected from an established category 

(i.e., possessing a structural alert) while also being structurally similar to the target compound. In this 

approach, the source compounds may or may not exhibit quantitative variation for the biological response. In 

the case, where there is no relative variation, the endpoint values are read across in a similar fashion as in 

the analog approach. When there is significant variation, there may be the opportunity to establish a linkage 

between a descriptor common to the source structures and the target and the biological response. 

 

The Leadscope Read Across Tool is an application module for performing a read across assessment of a target 

chemical for a biological response. The tool is a read across analysis workspace that can accommodate either 

an analog or category approach or a hybrid of the two. Operations are provided for populating the read across 

data matrix through the selection of structural analogs and biological response properties, management of 

source groupings, rule-based exclusions, aggregation of the biological response and finally generating a report. 

The report wizard can accommodate either a basic format or a Read-Across Assessment Framework (RAAF)-

compliant format (ECHA, 2017). 

 

This chapter describes the Read Across Tool functionality, including the topics listed below. 

 

¶ Getting started with read across 

¶ Identify target 

¶ Read Across Tool interface overview 
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¶ Structures tab view 

¶ Groups tab view 

¶ Exclusions tab view 

¶ Read Across tab view 
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Getting Started with Read Across 

The read across tool can be launched in the Leadscope Explorer Tasks View by selecting the button of the 

same name from the toolbar. 

 

Launching read across will open a Model Applier ς Read Across window where you can choose to create a 

new analysis with Start New Read Across, open an existing analysis with Select Read Across or if you have a 

set of compounds to import to Leadscope use the LƳǇƻǊǘ ¢Ŝǎǘ {Ŝǘ Χ shortcut (Figure 7-1). 
 

Figure 7-1: Initial read across options 

 

Identify Target 

The first step in setting up a new read across assessment is to identify the target chemical. The Leadscope 

tool is flexible in that it allows for multiple target input options (Figure 7-2). 

 

Find a loaded structure by name or id this option will search for the target compound n the 

Leadscope database matching the compound’s ID, CAS 

Registry ID, chemical name or trade name. More than one 

result may be returned, in which case you will have the 

opportunity to select the correct target compound from 

the results after clicking Next (Figure 7-2). 
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Figure 7-2: Identify read across target chemical 

Use a previously loaded test set this option allows you to browse to a Leadscope project 

that contains the target structure (Figure 7-2). If there is 

more than one compound in the selected project, you will 

be able to select the target from the members of the 

project in the next screen (Figure 7-3). 
 

Enter a single structure below here you can browse to a chemical structure file (.mol, 

.sdf) to import it into Leadscope and create an associated 

project. You have the option to enter the target’s SMILES 

notation, browse to a MOL file containing the target or 

paste it into the form from a chemical drawing package. 

The Name: field is important as it allows you to enter, or 

alter, the target’s name, which will be the primary 

identifier for the structure in Leadscope (Figure 7-2). 
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Figure 7-3: Select read across target from a set of chemicals 

After you have identified the target chemical, the next step is select a target biological response (Figure 7-4) 

as a preferred study type to include in the read across report. 
 

 

Figure 7- 4: Choose read across source study type 
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Read Across Tool 

The Read Across Tool interface is the primary workspace for performing a read across assessment. This 

workspace has four distinct tab views each associated with a navigation tab (Figure 7-5). 
 

 

Figure 7-5: Read Across Tool tabs 

The read across tab views include: 

 

Structures 

This tab view is the main read across interface containing the target structure and data matrix 

along with utilities for manipulating the matrix. 

 

Groups 

This view is an interactive interface for any groups of source chemicals that have been included 

or excluded in the read across analysis. 

 

Exclusions 

The Exclusions tab view provides an accounting of any exclusion rules applied in the analysis. 

 

Read Across 

The Read Across tab view is where the current assessment can be summarized and reports can 

be generated. 

 

Read Across Tool Menu Bar 

In the Structures tab view the menu bar consists of File (Figure 7-6), Edit (Figure 7-7) and Tools (Figure 7-8) 

dropdown menus each containing options specific to the current view. 
 

The File dropdown menu has options for saving, exporting and reporting on the read across analysis (Figure 

7-7). The Edit dropdown provides access to utilities such as adding analogs to the data matrix, adding 

categories of structures, creating exclusion rules and manipulating the data matrix (Figure 7-8). The Tools 

menu includes options for calculating new data from existing columns in the data matrix and explaining 

prediction results for both the target and source structures (Figure 7-9). 
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Figure 7-6: File 

dropdown menu 

Save 
 

/ǊŜŀǘŜ .ŀǎƛŎ wŜǇƻǊǘΧ 

/ǊŜŀǘŜ w!!C wŜǇƻǊǘΧ 

Export Data Matrix as 

¢ŀōƭŜΧ 

Publish Data aŀǘǊƛȄΧ 

Print Data Matrix to P5CΧ 

Saves the current read 
across analysis 

 

Generate a generic read 

across report Generate a 

RAAF-compliant report 

Export the current data matrix to a 

spreadsheet file (.txt, .csv or .xls) 

 

Create a PDF file of the current data 

matrix 

Print the Data Matrix to a 
PDF file 

 

Figure 7-7: Structures tab view 

Edit menu 

Undo (Ctrl+Z) 
 

Add Analog 

{ǘǊǳŎǘǳǊŜǎΧ 

 

 

!ŘŘ /ŀǘŜƎƻǊȅΧ 

 

!ŘŘ 9ȄŎƭǳǎƛƻƴ wǳƭŜΧ 

!ŘŘ 5ŀǘŀΧ 

!ŘŘ ¢ŜȄǘΧ 

 

!ŘŘ tǊŜŘƛŎǘƛƻƴǎΧ 

wŜƻǊŘŜǊ κ wŜƳƻǾŜ 5ŀǘŀΧ 

 

Reorder / 

wŜƳƻǾŜ ¢ŜȄǘΧ 

 

 

Remove Data / 

tǊŜŘƛŎǘƛƻƴǎΧ 

Undo the last operation 
 

Add source structures similar to the 
target structure to the data matrix 
Generate a RAAF-compliant report 
Add a category of source structures to 
the data matrix 

Add an exclusion rule to 
the source structures 

Add numeric data to the data matrix 

Add text data to the data matrix 

Add (Q)SAR model 

prediction results to the 

data matrix 

Rearrange the order of data columns or 

remove columns of numeric data from 

the data matrix 

Rearrange the order of 

data columns or remove 

columns of text data from 

the data matrix 

Remove data or prediction 
results from the matrix 
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Figure 7-8: Structures tab view 

Tools menu 

Calculate New 
Data 

/ƻƭǳƳƴΧ 

 

Explain Target Structure 

tǊŜŘƛŎǘƛƻƴǎΧ 

 

Explain Source Structure 
tǊŜŘƛŎǘƛƻƴǎΧ 

 

Opens the Calculate New 
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Structures Tab View 

The Structures tab view includes the read across data matrix and tools for manipulating the matrix. This view 

is divided into several navigation sections including the menu bar, a toolbar, navigation tabs providing access 

to other views and the data matrix. The data matrix includes a locked target structure row above a source 

structure spreadsheet (Figure 7-9). 
 

 

Figure 7-9: Read across tool Structures tab view navigation overview 

Structures Tab View Toolbar 

The Structures tab view toolbar contains utilities for manipulating the data matrix organized by source 

chemical and data operations (Figure 7-10). 
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Figure 7-10: Read across toolbar in the Structures context 

 

Source Chemical Operations 

Add Analogs Search for chemical structure analogs with a specified Tanimoto coefficient 

cutoff and limited by a numeric dataset, Leadscope project or study type 

(Figure 7-11). 

 

 

Figure 7-11: Add analogs dialog 
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Add Category Identify similar structures belonging to the same defined category 

structure category including from alert sets, substructures 

provided by an SDF or MOL file or pasted from the Clipboard 

(Figure 7-12). 

 
 

Figure 7-12: Add category dialog 

Add Exclusion Rule Create an exclusion rule based on chemical substructure (Figure 7- 

14) or using a property value (Figure 7-13) to remove matching 

source analog chemicals. 
 

 

Figure 7-13: Create exclusion rule By Column Value dialog 
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Figure 7-14: Create exclusion rule By Matching Substructure 

Exclude Structures Exclude selected source structures from the read across analysis,  

A dialog will open where you can record the justification for 

the exclusion (Figure 7-15). 
 

 

Figure 7-15: Exclude structures dialog 

 

Source Data Operations 

Add Data Add numeric endpoint data from the Leadscope database to the 

source structures spreadsheet. 

Add Text Add text data to the source structures spreadsheet. 

Add Predictions Add (Q)SAR prediction results to the data matrix from the 

available models in Leadscope. 

              Remove Data/Predictions             Remove data and/or predictions from the data matrix. 
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Read Across Data Matrix 

The Structures view tab spreadsheet is the main read across workspace containing the data matrix. The first 

row of the spreadsheet is a locked row for the target structure. The remaining rows are for the source 

structures. By default, the matrix includes only the target structure row and after adding analogs to the 

matrix the matching source structures will occupy the following rows. Initially, the data columns will include 

the similarity score for the source structure and the name of the group the structure belongs (such as Analog 

Structures (>0.4)) (Figure 7-16). 
 

Figure 7-16: Structures view spreadsheet with “Pyri proxifen” as the target structure and a series of source analogs following it 
ranked by their s imilarity scores. 
 

Groups Tab View 

The Groups tab view lists the groupings that have been added to the read across. Groupings can include 

source structures included from a category or analog source structures that have been added to the read 

across data matrix. This view is also where you can remove or edit groupings of structures (as opposed to the 

Structures view where you can only exclude selected structures). 
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The Groups view includes a menu bar, toolbar and spreadsheet listing the current groupings applied in the 

read across. The spreadsheet data columns will include the Frequency and the mean of any data columns 

from the data matrix (Figure 7-17). 
 

Figure7-17: Example Groups tab view showing an analog structures group with the frequency column and mean data columns 

for the same data columns present in the overall data matrix 

Groups Tab View Taskbar 

The Groups tab view toolbar includes two operations specific to the view – Edit Grouping and Remove 

Grouping. The Edit Grouping option allows you rename the group and edit any comments associated with 

the group (Figure 7-18). The Remove Grouping option will remove the group from this view and from the 

read across data matrix. 
 

 

Figure 7-18: Edit grouping dialog 
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Exclusions Tab View 

The Exclusions tab view is where excluded groups of source structures are recorded. These exclusions can 

include sets of structures manually excluded from the data matrix with the Exclude Structures tool or sets of 

structures excluded based on an exclusion rule. 
 

 

Figure 7-19: The Exclusions tab view provides a list of the exclusions included in the read across. 

Exclusions Tab View Toolbar 

The Exclusions tab view toolbar includes two operations specific to the view – Edit Exclusion and Remove 

Exclusion (Figure 7-20). The Edit Exclusion option allows you to change the name of the exclusion and alter 

the exclusion details or justification and the Remove Exclusion option will remove the exclusion placing the 

excluded source structures back into the data matrix (provided they haven’t been excluded elsewhere). 
 

Figure 7-20: The Exclusions toolbar includes the same general operations as the other tab views in addition to two specific 
operations - Edit Exclusion and Remove Exclusion 

Exclusions Tab View Spreadsheet 

Figure 7-19 shows the Exclusions tab view spreadsheet populated with an exclusion named ALogP < 0 or > 5. 

By default, the number of compounds excluded (the Frequency column) and the mean value for each of the 

data columns in the data matrix is included in the spreadsheet. To edit or remove the exclusion rule, select its 

row in the spreadsheet and choose either Edit Exclusion or Remove Exclusion from the toolbar. The Edit 

Exclusion option allows you to change the name or edit the Comments field (Figure 7-18). 
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Read Across Tab View 

The Read Across tab view is where you can calculate the target read across score and to generate a report 

describing the analysis. The target read across score is the endpoint value to be assigned to the target 

structure based on the read across analysis. This value is calculated from one of the data columns in the data 

matrix (specified in Figure 7-21 using the Endpoint Data: dropdown menu) with one of three methods listed 

below. 
 

Figure 7-21: Read Across tab view including options to aggregate the source endpoint values and the final Resulting Target 

Read Across Value. 

Aggregate of endpoint values 

 

The read across target endpoint can be calculated based on an aggregate of the endpoint values 

from the source records as the minimum, maximum, mean or median value. 
 

Regression of other data from source structures 

 

This option will create a regression curve of the target endpoint. A scatterplot of the curve is 

available by selecting the Show Scatterplot button. By default, the scatterplot compares the target 

endpoint to itself (on both axes). One or both of these datasets can be replaced with other 

properties by right-clicking the dataset name on the axis (Figure 7-22). 

 

 

 

 



125 Leadscope Client User Guide – Version 3.8 

Proprietary and Confidential 

 

Proprietary and Confidential 

 

 

 

 
 

Figure 7-22: Manipulating the regression scatterplot endpoints 

For instance, replacing one of the Bacterial Mutation endpoints in Figure 7-22 with Molecular 

Weight 

will generate a new plot with the Molecular Weight dataset as the x-axis shown in Figure 7-23. 

 

 

 

 

Figure 7-23: The scatterplot was modified to include Molecular Weight as the x-axis dataset and Bacterial 
Mutation as the y-axis dataset 
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Manually (or externally) determine value 

 

The read across result can also be specified manually by entering a target value based on an external 

analysis. 

 

Read Across Tab View Toolbar 

The Read Across toolbar includes the same operations as the toolbars in the other view, with the addition of 

the Show Scatterplot Matrix operation. This will create matrix of scatterplot graphs comparing the 

properties from the current data matrix (Figure 7-23). 
 

 

Figure 7-24: The Show Scatterplot Matrix option will create a matrix of scatterplot graphs comparing the data matrix 
endpoints. In this figure, the Leadscope calculated properties and the Bacterial Mutation endpoint are compared. 

Reporting 

There are two reporting options – Basic Report and RAAF Report each with a specific button in the Read 

Across tab view. Either option will open a report wizard that will walk you through assembling a final report 

archive. The Basic Report is a comprehensive general report format that allows you to detail and justify the 

target structure, the read across context and hypothesis, the inclusion of source structures and data, the 

exclusion of source structures and the applicability domain considered in the assessment. The RAAF Report 

allows you to provide similar justifications as the basic report, while also providing additional pages specific 

to the type of RAAF read across scenario selected. 

 

Basic Report Wizard 
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Figure 7-25: Basic Report Wizard steps 

For each target or source structure, individual studies can be removed completely from the analysis using the 

Remove Study button or selected to be included/excluded (but still present in the analysis) in the final report 

with the Yes/No option (Figure 7-26). 
 

 

Figure 7-26: Choosing to include/exclude the study versus removing the study 
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After the study selection steps is the Executive Summary page (Figure 7-27).  An overall assessment, summary 

of the read across hypothesis and other comments can be entered here. The overall assessment is selected 

from a dropdown menu (Figure 7-28), with options for Not assigned, Acceptable, Acceptable as part of 

weight of evidence and Not acceptable. A Read-across prediction score is automatically populated from the 

Read Across view. 
 

 

Figure 7-27: Basic Report Wizard - Executive Summary page 

 

Figure 7-28: Basic Report overall assessment 
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After completing the Executive Summary, the pages that follow detail the read across target profile, context 

and hypothesis. The first page is Target assessment (Figure 7-29), where the target can be detailed. There 

are fields for entering various types of identifiers for the target substance, such as name, IUPAC chemical 

name, other names, EINECS identifier, CAS registry identifier and other identifiers. 
 

 

Figure 7-29: Basic Report Wizard - Target Assessment page 

The next page is Purpose of use, where the context of the read across analysis can be entered in a comments 

field and/or an image illustrating the context can be uploaded (Figure 7-30). Example context comments are 

provided, such as “Hazard characterization for a screening level risk assessment”. 
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Figure 7-30: Basic Report Wizard - Purpose of Use page 

After establishing the read across context, the hypothesis can be detailed. In Figure 7-31, the hypothesis is 

seeded with details applied to the read across analysis including the groupings applied (analog structures > 

40% similar) with a definition summary and a summary statement of the source structures. Additional 

comments should be entered as a justification for the similarity cutoff selected. 
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Figure 7-31: Basic Report Wizard - Hypothesispage 

The following pages allow you to justify exclusions and exclusion rules that have been applied to the read 

across (Figure 7-31) and the applicability domain of the read across. Exclusions include the manual removal of 

potential source structures and/or the application of a specific exclusion rule (such as based on a property 

cutoff or substructure rule). The exclusions should be justified using the comments field. 
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Figure 7-32: Basic Report Wizard - Exclusions and Exclusion Rules page 

The applicability domain of the read across analysis should detail what domain constraints were considered 

for the source structures and subsequently applied to the target structure (Figure 7-33). The comments field 

should include this justification and an image file supporting the justification can be uploaded. 
 

 

Figure 7-33: Basic Report Wizard - Applicability Domain page  
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The final pages include the justification of the read across (Figure 7-34) and the conclusion (Figure 7-35). The 

justification should include comments supporting the analog or category arguments.  Figures can be uploaded 

as image files. 
 

Figure 7-34: Basic Report Wizard - Justification page 

The conclusion should provide an overview of the assessment and the final conclusion assigned to the target 

substance. Figures and supplemental files can be uploaded here. 
 

 

Figure 7-35: Basic Report Wizard - Conclusion page 
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The final page is to generate the report (Figure 7-36). The report file is a ZIP archive file and should be 

specified in the Filename field. The report format (RTP or PDF) can be selected under Report format: and a 

title page can be toggled on or off with the Include title page: checkbox. The title page includes fields for the 

title, contact person and their contact details, other information, report version number and a date checkbox. 

The report appendices can also be selected including whether to include  detailed  in silico prediction reports 

and if selected whether to include the Explain reports for prediction results, the reference and/or training set 

analog structures, any database analogs relative to the in silico models applied, and if expert alert models 

where applied, examples of the alert structures. The study reports (both from Leadscope and 

proprietary/external studies) can be included as supporting information in PDF format with the Study reports 

checkbox. 
 

 

Figure 7-36: Basic Report Wizard - Generate Report page 

 

References 

ECHA (2017). Read-Across Assessment Framework (RAAF). Helsinki, Finland: European Chemicals Agency. 

 

OECD (2007). Guidance Document on the Validation of (Quantitative) Structure-Activity Relationships 

[(Q)SAR] Models. OECD Series on Testing and Assessment No. 69. ENV/JM/MONO(2007)2. Paris, France: 

Organisation for Economic Cooperation and Development. 



136 Leadscope Client User Guide – Version 3.8 

Proprietary and Confidential 

 

Proprietary and Confidential 

 

 

 

 

CHAPTER 8 
 

 

 
 

SDF Editor 
 

 

Overview 

The SDF Editor is a molecular spreadsheet application for editing, combining, and parsing chemical structure 

files. It enables you to modify these files based on properties and/or chemical structures as a standalone 

application outside of the Leadscope client. It could be used to clean up structure files for use within 

Leadscope and other tools. 
 

This chapter describes the SDF Editor Tool functionality and includes the topics listed below. 

 

¶ Getting started with the SDF Editor 

¶ Adding data and structures from files 

¶ Adding and removing properties and structure names 

¶ Find and Replace, Sort, and toggling the structure pictures 

¶ Calculating and merging properties 

¶ Finding and transforming structures 

¶ Finding and merging duplicate structures 

¶ Mixtures 

¶ Saving, exporting and publishing a report 

Getting Started with the SDF Editor 

To begin using the tool, either select the SDF Editor button from the Tasks View toolbar or, from any View, 

choose Tools -> SDF Editor (Figure 8-1). The SDF Editor is also provided as a standalone application bundled 

with the Leadscope Client and is available in the Leadscope Client group under the Microsoft® Windows Start 

Menu. 
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Figure 8-1: Launch the SDF Editor from the Tools menu 

Launching the SDF Editor will open a new application window. In this window, there are 4 menus - File, Edit, 

View, and Tools. The File menu contains options for spawning a new SDF Editor window, opening a chemical 

structure file (including MOL, SDF, and SMILES formats), adding data from a delimited text file to the 

spreadsheet, saving and exporting the spreadsheet, publishing a report or chemical structure grid to a PDF or 

RTF file, and closing the application (Figure 8-2). 

 

 

Figure 8-2: SDF Editor File menu options 
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Adding data and structures from file 

The first step is to open a chemical structure file using File -> Open SDF/Mol/SMILES... 

 

You can now add data to the SDF file from a text-delimited spreadsheet file using File -> Add Delimited Data. 

The property file should be a tab-delimited text spreadsheet file (.TXT) with the chemical structure ID in the 

first column. You also have the option of adding data from an SDF file with matching structure names. 

You should now have a spreadsheet with chemical structures in the first column with a series of data columns 

such as in Figure 8-3. 

 

 

Figure 8-3: Example chemical structures with data 

 

Adding and removing property and structure names 

The Edit Menu includes the traditional editing and select tools in addition to options specific to chemical 

structure files such as: 
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Add or Remove Property – not to be confused with adding data from a delimited text file in the File 

menu, these options allow you to create a new property without data 

 

Edit the chemical structure ID – there are five structure ID editing choices – use a property as the ID, 

add a prefix to the ID, add a prefix based on a property, add a suffix to the ID, or assign the row 

number as the ID 

 

Hide rows or hide/reorder columns – these options allow you to hide selected or unselected 

chemical structure records (rows) or to hide or reorder properties (columns) 
 

Figure 8-4: SDF Editor Edit menu options 

 

Find, replace, sort and toggling of structures 
 

The View Menu includes options to find and replace, sort, and toggle the structures (Figure 8-5). 
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Figure 8-5: SDF Editor View menu options 

 

Calculating and merging properties 

Figure 8-6 shows the Tools menu which includes groups of operations for properties, structures and mixtures. 

The property tools available include creating new datasets from existing properties from a function, 

calculating new properties (physicochemical), and merging properties. 
 

 

Figure 8-6: SDF Editor Tools menu options 

The Tools->CalcǳƭŀǘŜ tǊƻǇŜǊǘƛŜǎΧ option opens an interface for calculating a new property from existing 

properties with a set of mathematical operators (Figure 8-7). When the function is complete, the new 

property can be previewed using the tǊŜǾƛŜǿ ±ŀƭǳŜǎΧ option and then named before saving. 



141 Leadscope Client User Guide – Version 3.8 

Proprietary and Confidential 

 

Proprietary and Confidential 

 

 

 

 
 

Figure 8-7: Create property function interface (Tools -> Calculate Properties) 

Another property related option is to calculate additional physicochemical properties (Tools->Calculate 

Properties) for the structures in the molecular spreadsheet. The available properties are listed below. 
 

ALogP Atom Count 

Atom Count (Parent) 

Charge Centers (Negative) Charge Centers (Positive) Hydrogen Bond Acceptors Hydrogen Bond Donors 

Lipinski Score 

Molecular Weight 

Molecular Weight (Parent) Polar Surface Area 

Ring Count 

Rotatable Bonds 
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Another option is to merge two properties together, discarding one and keeping another (Figure 8-8). 

 

 

Figure 8-8: Tools -> Merge Properties Tool 

 

Finding and transforming structures 

The Tools menu includes operations for reducing the structure set based on specified chemical criteria or by 

ID and options for chemically transforming the structure records. The Tools-> Find Structures from Criteria 

opens an interface where the options for reducing the structure set can be selected.  The options  are 

grouped by the component nature of the structure, the chemical type, the structure’s connection table 

coordinate type, a structure query or by convention (presence of a pentavalent nitrogen, containing aromatic 

bonds in the connection table), based on stereochemistry, based on other attributes (charge, isotope), and 

whether the structure passes the Leadscope validation check (Figure 8-9). 
 

 

Figure 8-9: Select Structures from Criteria interface 
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Rather than reducing the structure set, the Tools -> Transform Structures will alter the structure’s 

connection table (Figure 8-11). The transformation options can be performed on the entire set or against a 

selected subset and are listed below. 
 

 

Figure 8-10: Transform Structures options 
 

Remove stereo convert stereo bonds to non-stereo form 

Remove isotopes strip isotopes from the structure 

Remove salts strip all salts from the structure based on 
the list of 

organic and inorganic salts in Appendix 2 

Remove duplicate fragments strip unconnected duplicate fragments 
from 

structures 

Denormalize aromatic bonds transform aromatic bond types to Kekulé 
format 

Neutralize charged structure replace charged fragments with neutral 
species 

Make pentavalent nitrogen fragments 
charge- separated 

replace pentavalent nitrogen fragments with charge- 
separated fragments 

Neutralize charge-separated 
pentavalent nitrogen 

convert charge-separated nitrogen 
fragments into 
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fragments pentavalent form 

Regenerate 2D coordinates perform 2D coordinate generation on the 
selected 

structures 

Dates (add missing) add a modification date to structures 

Convert to SAR form neutralize the structure and strip salts 

 

For instance, in Figure 8-11, the substance 6-Monoacetylmorphine (6-MAM) is transformed to a 

representation with no stereo bonds with the Remove stereo option, then the structure re-drawn using the 

Regenerate 2D coordinates option. 
 

Figure 8-11: 6-MAM i s transformed using the Remove stereo option followed by the Regenerate 2D coordinates 
option 
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The connection table for a structure record can be accessed by double clicking the structure in the SDF editor 

spreadsheet window (Figure 8-12).  The structure record is opened in the Structure Analysis window.  Here, 

the connection table can be validated, transformed or edited in the local chemical structure drawing 

package. 

 

 

Figure 8-12: Structure Analysis window showing the structure’s connection table 

 

Finding and merging duplicate structures 

There is an option to find duplicate chemical structure records by exact match structure query with selections 

for matching stereochemistry or charges, or find duplicate records based on ID within the tools menu (Tools- 

> Find Duplicate Structures). You also have an option to merge duplicate structures in the spreadsheet (the 

merged record ID will contain the duplicate record IDs as a semi-colon delimited list) (Tools -> Merge 

Duplicate Structures) 
 

Mixtures 

Mixtures can be split into separate structure records (Tools -> Split Mixtures). 

 

Saving, exporting and publishing a report 

You could save the SDF file under a new name and location using the Save as tab in the file menu. You could 

also save each individual structure as a MOL file in a zip achieve. The contents of the SDF file may be exported 

to an excel format (.xls), comma-separated values format (.csv), or tab de-limited text format (.txt). You 

could also publish an Adobe PDF (.pdf) or rich text format (.rtf) formatted report. 



146 Leadscope Client User Guide – Version 3.8 

Proprietary and Confidential 

 

Proprietary and Confidential 

 

 

 

 

APPENDIX ONE 

 

 

 
 

The Feature Hierarchy 
 

 

The Leadscope Feature Hierarchy includes approximately 27,000 chemical structure features chosen to 

represent those typically found in small-molecule drug candidates. When you create a new project, a 

systematic substructure analysis is performed using the pre-defined features stored in the feature library. 

The Feature Hierarchy is the chemical intelligence behind the Leadscope software. It provides a convenient 

way to categorize and visualize chemical compounds, allowing you to make research decisions rapidly. 
 

Nomenclature 

Structural features are assigned a chemical name based on the systematic nomenclature formalized by 

Chemical Abstracts Service.1 Most features are named as a parent followed by substituent prefixes, written in 

an inverted fashion for sorting. For example, 2-amino-1-butanesulfonic acid would be written as 1- 

butanesulfonic acid, 2-amino. Because the feature templates represent substructures that may contain 

generic atoms or bonds, there are some differences and ambiguities in the nomenclature. The psi notation is 

used in the Peptidomimetics class. In this notation, replacement of the CO-NH group is indicated by followed 

by the new group in brackets. For example, the notation is used below to indicate the reversal of the CO-NH 

group. 

 

 

 

Figure X1-1: Example of the Psi Notation in the Peptidomimetics Class 
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Major Structural Classes 
 

 
Figure X1-2: Major Structural Classes of the Hierarchy 

The major structural classes included in the Entire Hierarchy are shown in Figure X1-2. You can view the 

features within each major class by clicking the beside the class name to expand each hierarchy. The features 

are arranged alphabetically, beginning with the name of the parent structure, followed by any substituent(s), 

and then by any locants or qualifiers, such as t-(tertiary) or s-(secondary). All features in the hierarchy are 

substructures; they are defined as queries and recognized using substructure search techniques. You can 

double-click the name of a feature in the expanded hierarchy to open a detail window defining the 

substructure query. For example, expanding Heterocycles, followed by Pyrrole, then pyrrole, 3- R, and right- 

clicking pyrrole, 3-hydroxymethyl then selecting Definition ... opens the window illustrated in Figure X1-3. 
 

 

Figure X1-3: pyrrole, 3-hydroxymethyl- Feature Definition 

Specific definitions restrict the match for an input structure to a particular query.  In the query above, there 

are several restrictions on atom 6. All other positions are open and are not restricted. For example, the 

central portion of the following input compound matches the pyrrole, 3-amino query, and thus would match 

that feature within the hierarchy. 



148 Leadscope Client User Guide – Version 3.8 

Proprietary and Confidential 

 

Proprietary and Confidential 

 

 

 

 

 

 
 

Figure X1-4: pyrrole, 3-amino Matching Substructure 

It is important to understand that other portions of the input compound are likely to fit other structural 

queries in the hierarchy. A single compound will therefore be categorized in numerous classes within the 

hierarchy. The major structural classes and corresponding features are discussed below. 

 

Amino acids 

The 20 naturally occurring Amino acids, plus homocysteine, homoserine, isovaline, and ornithine in D-, L- and 

non-sterospecific forms are contained in this class. The generalized substructure (L-form) is: 

 

 

 

 
 

 

 

Figure X1-5: Amino Acid Generalized Substructure (L-form) 

where Z represents N, S, or O. N1 is either terminal or singly bonded; no heteroatom attachments are 

allowed. Atom 2 and all carbon atoms of the R-group are closed to further substitution. Heteroatoms in the 

R-group, such as the side chain hydroxyl, may be substituted. For example, the structural definition for L- 

serine is shown in Figure X1-6. 
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Figure X1-6: L-serine definition 

In addition to the specific Amino acids, two generic forms, - and -, are included, serving as generalized 

substructure queries. 

 

Bases, nucleosides 

This class contains the purine and pyrimidine bases adenine, cytosine, guanine, thymine, and uracil, their N- 

glycosyl derivatives, and the nucleosides inosine and xanthosine. For the nucleosides, both the d-ribo and 2'- 

deoxy-d-ribo glycosides— specific stereo and non-stereospecific (NS)—are included. 

 

Benzenes 

The Benzene class is divided into five major categories: 1,2-,1,3-, and 1,4-substituted benzenes, substituents, 

and substitution patterns. 1,X-Substituted Benzenes (X = 2,3,4) This level of the Hierarchy contains 1,X- 

disubstituted benzene rings with a wide variety of substituents. A 3-level structure exists for these subclasses 

terminating with the features listed at the third level. This is demonstrated below for the 1,2-substituted 

benzene feature definition: 
 

There is an inherent redundancy in the class hierarchy. For example, benzene, 1-amino, 3-chloro can be 

found under benzene, 1-R, 3-amino and under benzene, 1-R, 3-chloro. In addition, Benzene-containing 

groups are found as substituents in many other structural categories. 

 

Substituents 

This level of the Hierarchy contains substituted Benzenes with a wide variety of substitutions at a single ring 

position. Other positions on the ring are also open to substitution. 
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Substitution Patterns 

This level contains all Benzene rings substituted by either an acyclic atom or any fused ring atom. All possible 

combinations and positional variations with 1-4 substituents are included. Open positions in the ring are 

substituted by hydrogen. The substituents class has specific groups such as methyl, chloro, n-butyl attached to 

a benzene ring with no information about what is attached to any of the other benzene ring positions. The 

substituent patterns class is only concerned with the positional pattern of substitution such as 1- or 1,3- or 

1,3,4- but in this case without regard to what the substituent actually is, except that it is either cyclic or 

acyclic. 

 

Carbocycles 

Common ring systems such as adamantane are contained in this hierarchy. Bridged and spiro ring systems 

are also found here. 

 

Carbohydrates 

A large variety of 4-, 5-, and 6-carbon monosaccharides are contained here within five major sub-branches. 

These sub branches are furanoses, pyranoses, pentoses, hexoses, and inositols. In all cases, the OH 

substituents have been replaced with a Z (representing {N,S,O}) in order to include the common amino and 

thio analogs of sugars. Each feature is represented in D-, L-, and No Stereo (NS) forms. The anomeric carbon 

of the furanoses and pyranoses may have either stereochemistry. 

 

Elements 

This class contains features of the form E-A, where E = {As, B, M, P, Se, Si, Te}; M = any metal atom, and A = 

any atom. The bond between E and A is any type. The primary function of this class is to provide you with a 

convenient method for eliminating compounds containing undesired atoms. 

 

Functional Groups 

The main functional group classes are listed in table X1-1. Most of these classes are familiar, but a few 

deserve special attention and will be addressed separately below. Appendix 3 lists additional functional 

groups not appearing in Table A and also directs you to their location within the hierarchy. Appendix 4 

provides details on substituent groups; many share similar definitions as features within the functional group 

class. 
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TABLE X1-1. Main 

Functional Group Classes 

Acid anhydrides 

Acid alcohols 

Alcoholsa 

Aldehydes 

Alkenesa 

Alkynesa 

 
 

Allenes 

Amidines 

Aminesa 

Azides 

Boron groups 

Carbamates 
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Carbonyls 

Carboxamidesa 

Carboxylatesa 

Carboxylic acidsa 

Ethers 

Guanidines 

Halidesa 

Hydrazinesa 

Hydroxylamines 

Imines 

Iminomethylsa 

Isocyanates 

Isonitriles 

Ketones 

Mercaptans 

Misc. nitrogen groups 

Misc. oxygen groups 

Misc. sulfur groups 

Nitriles 

a. 
Found as substituents in other parts of 

the hierarchy. 

Nitroa 

Nitroso 

Organometals 

Phosphorous groups 

Quinines 

Silicon groups 

Sulfides 

Sulfonamides 

Sulfonates 

Sulfones  

Sulfonic acids 

Sulfonyl groupsa 

Sulfonyl halides 

Sulfoxides 

Thiocarboxamides 

Thiocarboxylates 

Thiocarboxylic acids 

Thioxomethyls 

Ureas 
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1. Alcohols: Also found as hydroxyl and hydroxymethyl substituents in other parts of the hierarchy. 

 

2. Alkenes: This subclass contains mostly alkenes and dienes with carbon substituents in a variety of 

substitution patterns. Heteroatom substituted alkenes, such as enol ethers and halo alkenes, are found under 

ethers and halides, respectively. Alkenes are also found as alkenyl substituents in other parts of the hierarchy. 
 

3. Alkynes: Also found as alkynyl substituents in other parts of the hierarchy. 

 

4. Amines: The term amine is defined as an sp3 hybridized nitrogen with no charge and no direct heteroatom 

attachments. Because of their importance in medicinal chemistry, this hierarchy contains an extensive list of 

both specific and generic amine groups. Primary, secondary, tertiary, and quaternary amines are listed 

separately, as are their specific and generic derivatives. Aminium groups are also contained within this sub- 

class. For the amines listed here, carbonyl groups are prohibited as attachments. For example, N,N-dimethyl 

acetamide is not classified as a tertiary amine. In other parts of the hierarchy, however, amino substituents 

do permit carbonyl groups as attachments. 
 

5. Boron groups: The only boron-containing group is borate. 

 

6. Carbonyls: This group includes substructures with the general form: 

 

 

where Z = N, S, O; A is any atom; and R is a substituent. In a small number of cases, Z = C, e.g. alkoxymethyl- 

carbonyl. Substitutions on the carbon are also found under aldehydes, carboxamides, ketones, and so forth. 

Substituent patterns on multiple heteroatom attachments to the carbonyl group are also found under 

carbamates, ureas, and so forth. Iminomethyl and thioxomethyl are analogous categories for the 

replacement of the carbonyl oxygen with nitrogen and sulfur, respectively. 

 

7. Misc. Nitrogen Groups: N-containing functional groups infrequently encountered in drug candidates are 

listed here. Examples: 
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8. Misc. Oxygen Groups: Similar to the misc. nitrogen group subclass, this group includes O-containing 

functional groups not frequently encountered in drug candidates. Examples: 

 

 
9. Misc. Sulfur Groups: S-containing functional groups uncommon in drug candidates are listed here. 

Examples: 
 

 
 

10. Nitriles: Also found as cyano substituents in other parts of the hierarchy. 

 

11. Phosphorous Groups: Variousphosphorous-containing groups can be found here. Examples: 

 
 

 

12. Silicon Groups: The only silicon-containing group is trimethylsilyl. 

 

13. Sulfides: Also found as thio substituents in other parts of the hierarchy. 

 

Heterocycles 
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The Heterocycles class contains nearly 60% of all the features in the Feature Hierarchy. It is the largest class, 

with 132 sub-classes. The subclasses can be further divided into two categories: rings with substituents and 

rings without substituents. 

 

Rings Without Substituents 

Table X1-2 lists the rings without substituents. 

 

TABLE X1-2. Heterocycle subclasses without substituents 

Bicyclic amines 

Episulfide 

Epoxide 

5,5-fused N-rings 

5,6-fused N-rings 

6,6-fused N rings 

Rings size 3-4 N+Z 

Rings size 4-7 O+S 

Z-rings size 8-14 

3,4-Ring systems 

Spiro amines 

Spiro aminoethers 

Spiro ethers 
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Spiro lactams 

Spiro lactones 

 

These subclasses have only one sublevel within the hierarchy. Each is discussed below. 

 

¶ Bicyclic amines: This set includes common bridged bicyclic systems with a single N atom. With the 
exception of the atropine and quinine nuclei, which have trivial names, the rings are named 
following the Von Baeyer rules for bridged systems.2 Examples: 

 
 

¶ Episulfide, Epoxide: Both classes are terminal nodes in the hierarchy containing only one structural 

query. 

¶ 5,5-, 5,6-, and 6,6-fused N-rings: These subclasses contain all ring fusion variants for any pair of 5- or 
6- membered rings with one or two nitrogens. For rings where both fusion atoms are carbon, the 

hierarchy contains two bond variants: an aromatic version and a non-aromatic version. The non- 

aromatic version will match any bond variation, saturated or partially saturated. The (H) in ring 

names indicates at least partial saturation. For rings where one or both of the fusion atoms are 

nitrogen, there is only one bond variant and the rings will match any bond variation. 

¶ Rings size 3-4 N+Z: 3- and 4- membered rings containing a nitrogen and a Z = {N,S,O}. The rings will 

match any bond variation. Examples: 

 

¶ Rings size 4-7 O+S: 4- through 7- membered rings containing one oxygen and one sulfur atom. The 

rings will match any structure definition. 

¶ Z-Rings size 8-14: 8- through 14- membered rings with at least one Z = {N,S,O}. All other atoms and 

bonds are generic. 

¶ 3,4-Ring systems: 3- and 4- ring systems that occur frequently in known drugs. Examples: 



157 Leadscope Client User Guide – Version 3.8 

Proprietary and Confidential 

 

Proprietary and Confidential 

 

 

 

 

¶ All Spiro classes: Spiro-joined 2-ring systems comprising 3- to 6-membered rings matching any bond 

variation. Examples: 

 

 
 

Rings with Substituents 

In the hierarchy, these ring classes are organized in a three-level fashion like that shown for the Benzene 
class. The parent ring is the first level, followed by ring parents with a generic R- group in the various 
substituent positions. Level 3 consists of rings with specific substituents at appropriate positions. Every open 
ring position corresponds to a branch in the hierarchy. The following Figure shows the levels for the pyridine 
system. 

 
 

Figure X1-4: Level system example for the pyridine subclass under Heterocycles 

All of the substituted ring classes are contained in Tables X1-3, X1-4 and X1-5. 

 

Table X1-3: Rings with one bond variant 

Azepine Oxetane 
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Azetidine Pyran(H) 

Aziridine 1,2,3,4-Tetrazine 

1,2-Diazepine 1,2,3,5-Tetrazine 

1,3-Diazepine 1,2,4,5-Tetrazine 

1,4-Diazepine Tetrazole 

1,3-Dioxane 1,2,3-Thiadiazole 

1,4-Dioxane 1,2,4-Thiadiazole 

1,3-Dioxolane 1,2,4-Thiadiazole 

1,4-Dithiane 1,3,4-Thiadiazole 

1,3-Dithiolane Thiane(H) 

1,2,3-Oxadiazole 1,3-Thiazepine 

1,2,4-Oxadiazole 1,4-Thiazepine 

1,2,5-Oxadiazole 1,2-Thiazine 

1,3,4-Oxadiazole 1,3-Thiazine 

1,3-Oxazepine 1,4-Thiazine 

1,4-Oxazepine Thiepin 

1,2-Oxazine Thietane 

1,3-Oxazine 1,2,3-Triazine 

1,4-Oxazine 1,3,4-Triazole 

Oxepin 

 

Table X1-4: Heterocycle classes with two fused rings 

1,2-Diazine(H) Pyrazine 

1,3-Diazine(H) Pyridine 

Furan Pyridine(H) 

Imidazole Pyrimidine 

Imidazolidine Pyrrole 

Isothiazole Pyrrolidine 

Isothiazolidine Thiazole 

Isoxazole Thiazolidine 

Isoxazolidine Thiolane 

Morpholine Thiophene 

1,4-Oxazine 1,2,4-Triazine 

Oxazole 1,2,4-Triazine(H) 

 

Table X1-5: Heterocycle classes with oxo substituents 



159 Leadscope Client User Guide – Version 3.8 

Proprietary and Confidential 

 

Proprietary and Confidential 

 

 

 

Benzimidazole, 2-oxo Purine, 2,6-dioxo 

Benzopyran, 2-oxo Pyrimidine, 2,4-dioxo 

Benzopyran, 4-oxo Pyrrolidine, 2-oxo 

5,1-Benzothiazepine, 2-oxo Quinazoline, 4-oxo 

1,2-Benzothiazine, trioxo Quinoline, 2-oxo 

1,3-Diazepine, 2-oxo Quinoline, 4-oxo 

Isoindole, 1,3-dioxo 1,2,4-Thiadiazine, dioxo 

Isoindole, 1-oxo 

 

Naphthalenes 

This class contains 1- and 2- substituted naphthalene rings with various substituents. The naphthalene may 

be further substituted and embedded in a larger ring system. 

 

Natural products 

The only subclass contained here is the steroid subclass. This class contains various singly substituted and 

partially unsaturated steroid ring systems. 

 

Peptidomimetics 

The peptidomimetics class contains only one subclass, amide bond mimetics. The features are dipeptide 

structures containing the amide bond surrogates as cited in Sawyer3 and highlighted in the figure below. 

The nomenclature used for the peptidomimetics class is discussed above, under the heading 

“Nomenclature.” 

 

 
Amide Bond Ψ [CONH] 

Examples: 

 

 

Pharmacophores 
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The features grouped here are pairs of generalized physiochemical atom types joined by a path of 3-8 

atoms/bonds of indeterminate type, i.e. 2-D topological pharmacophores. The physiochemical types are 

aromatic (ARO), hydrogen bond donor (HBD), hydrogen bond acceptor (HBA), and positive (PCC) and negative 

(NCC) charge centers. These features are very similar to the binding property pairs of Kearsley, et. al. ,4 

however we use the atom type definitions of Greene5 and Wang6 with suggested modifications from Dr. Jens 

Loesel (Pfizer, Sandwich), as follows: 

 

ARO (aromatic) 

An aromatic generic atom is any atom in an aromatic ring adjacent to an atom not in an aromatic ring. The 

path atom next to the aromatic atom must be non-aromatic. 

 

Hydrogen Bond Acceptors 

1. Any doubly bonded oxygen 

2. Any singly bonded oxygen, such as anion A—O- or hydroxyl A—OH 

3. Uncharged imine, nitrile, or aromatic N. Examples of imines include C=NH, or C=N—Ak; aromatic N 

includes ARO—N—ARO, where both ARO—N bonds are cyclic, aromatic 

4. An ether oxygen in the form C—O—C, where 

a. neither C is substituted by a doubly-bonded N, S, or O; e.g., neither C is part of a carbonyl 

b. at most one C is aromatic 

c. the O is acyclic 

d. C—O—C is cyclic, both C are sp3 hybridized 

5. Any doubly bonded sulfur in thioxomethyl C=S, where S has no other attachments 

 

Hydrogen Bond Donors 
 

1. Any OH not part of an oxo acid (A hydroxyl of an oxo acid is considered ionized at physiological pH 

and will be recognized as an HBA.) 

2. Any NH not in a tetrazole or N-trifluoromethyl-sulfonamide 

 

PCC (positive charge center) 

1. Cation, A+ but not A+—A-. 

2. Aliphatic amine: Ak—NH2, (Ak—)2NH, (Ak—)3N. 

3. Imino nitrogen of N,N-disubstituted amidines and tetrasubstituted guanidines. 

4. Tautomeric nitrogens of amidines and guanidines. 
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NCC (negative charge center) 

1. Anion, A- but not A-—A+. 

2. Tautomeric oxygen of an oxo acid. 
 

As an example structure, hacceptor-path4-pcharge would match the following chemical structure: 

 

 

Protective Groups 

The features contained here are the IUPAC-recommended blocking groups for heteroatoms. They are listed 

in Table X1-6, where Q is the attachment atom. Q = {N, S, O, P, Cl, Br, F, I, Si, Se, B}. 

 

Table X1-6: Protective Groups 

Leadscope Name IUPAC Name 

Acm-Q Acetomidomethyl- 

Ac-Q Acetyl- 

Boc-Q t-Butoxycarbonyl- 

Bpoc-Q 1-(biphenyl-4-yl)-1-methylethoxycarbonyl- 

Cbz-Q Benzyloxycarbonyl- 

CF3CO-Q Trifluoroacetyl- 

Ddz-Q , -Dimethyl-3,5-dimethoxybenzyloxycarbonyl- 

Dnp-Q 2,4-Dinitrophenyl- 

Dns-Q 5-(dimethylamino)naphtha-l-ylsulfonyl- 

Fmoc-Q Fluoren-9-ylmethoxycarbonyl- 

H2NCO-Q Carbamoyl- 
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HCO-Q Formyl- 

Ips-Q 4-Iodophenylsulfonyl- 

Mal-Q Maleyl- (HOOC-CH=CH-CO-) 

Nbs-Q (3-Carboxy-4-nitrophenyl)thio- 

Nps-Q 2-Nitrophenylthio- 

Ph3C-Q Triphenylmethyl- 

PhCH2-Q Benzyl- 

PhCO-Q Benzoyl- 

PhNHCS-Q Phenyl(thiocarbamoyl)- 

Phthalyl-Q Phthalyl- 

Pz-Q p-Phenylazobenzyloxycarbonyl- 

Q-Mal-Q Maleoyl- (-OC-CH=CH-CO-) 

Q-phthaloyl-Q Phthaloyl- 

Q-Suc-Q S uccinyl- (-OC-CH2-CH2-CO) 

Suc-Q -Carboxypropanoyl- (HOOC-CH2-CH2-CO-) 

Tos-Q Tosyl- 

Z(Br)-Q p-Bromobenzyloxycarbonyl 

Z(NO2)-Q p-Nitrobenzyloxycarbonyl- 

Z(OMe)-Q p-Methoxybenzyloxycarbonyl- 

Spacer Groups 

This class is based on the premise that many drug-like molecules contain carbon chains separating structural 

features important for their activity.8 The subclasses are organized by chain length and named as 1,n- 

derivatives of normal alkanes, from 1 <= n < 7. Atoms in the spacer are acyclic, unfunctionalized carbons with 

no heteroatom attachments. The structure of the hierarchy here is three-level, similar to that shown for both 

the Benzene and Heterocycle classes. An example of a Spacer Group substructure query is shown in Figure 

X1-7. 

 

Figure X1-7. Substructure Query of propane, 1-alkenyl,3-alkoxy-, located in the Spacer Groups class 
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APPENDIX TWO 

 

 

 
 

Salts 
 

 

The following tables describe the organic and inorganic salts that Leadscope uses to identify parent compounds, 

along with all amino acids: 
 

Table X2-1. Common Organic Salts 
 

Common Organic 
Salts 

Systematic Name 
CAS Reg Number 

Acetate Acetic acid 64-19-7 

Aceturate N-Acetyl-Glycine 543-24-8 

Amsonate 2,2’-(1,2-ethenediyl)bis[5-amino-
]Benzenesulfonic acid 

81-11-8 

Armstrong's 
acid 

1,5-Napthalenedisulfonic 81-04-9 

Ascorbate D-Ascorbic acid 10504-35-5 

Benzoate Benzoic acid 65-85-0 

Besylate Benzenesulfonic acid 98-11-3 

Brucine Strychnidin-10-one,2,3-dimethoxy- 357-57-3 

Butyrate Butanoic acid 107-92-6 

Camsylate 7,7-Dimethyl-2-oxo-
bicyclo[2.2.1]heptane-1-
methanesulfonic acid 

3144-16-9 

Caproate Hexanoic acid 142-62-1 

Carbamate Carbamic acid 463-77-4 

Carbanilate Phenyl-Carbamic acid 501-82-6 

Cinchonidine 2-Quinuclidinemethanol,alpha-4-
quinolyl-5-vinyl-(-) 

485-71-2 

Cinchonine 2-Quinuclidinemethanol,alpha-4-
quinolyl-5-vinyl-(+) 

118-10-5 

Cinnamate 3-phenyl-2-Propenoic acid 621-82-9 

Citrate 2-hydroxy-1,2,3-
Propanetricarboxylic acid 

77-92-9 
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Clofibrate 2-(4-chlorophenoxy)-2-methyl-
Propanoic acid 

882-09-7 

Cyclamate cyclohexyl-Sulfamic acid 100-88-9 

Cyclohexana
mine 

Hexahydrobenzenamine 108-91-8 

Cypionate Cyclopentanepropanoic acid 140-77-2 

Decanoate Decanoic acid 334-48-5 

Diethanolami
ne 

Ethanol, 2,2’-iminobis- 111-42-2 

Diethylamine N-ethylethanamine 109-89-7 

Dimethylamin
e 

Methanamine, N-methyl- 124-40-3 

Diphenylaceti
c acid 

Benzeneacetic acid, alphaphenyl- 117-00-8 
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Common Organic 
Salts 

Systematic Name 
CAS Reg 
Number 

Edetate N,N’-1,2-ethanediylbis[N-(carboxy-methyl)-
Glycine 

60-00-4 

Edisylate 1,2-Ethanedisulfonic acid 110-04-3 

Enanthate Heptanoic acid 111-14-8 

Ephedrine Benzenemethanol, alpha-(1-
(methylamino)ethyl)- 

299-42-3 

Estolate Dodecyl sulfate (mono salt) 151-41-7 

Esylate Ethanesulfonic acid 594-45-6 

Ethanol Ethyl Alcohol 64-17-5 

Ethanolamine Ethanol, 2-amino- 141-43-5 

Formate Hydrogencarboxylic acid 64-18-6 

Fumarate 2-Butenedioic acid (2E) 110-17-8 

Gluceptate D-glycero-D-gulo-Heptonic acid 87-74-1 

Gluconate D-Gluconic acid 133-42-6 

Glucose Glucose 50-99-7 

Glutamate L-Glutamic acid 617-65-2 

Glycinate Aminoacetic acid 56-40-6 

Glycolate Hydroxyacetic Acid 79-14-1 

Guanidine Guanidine 113-00-8 

Hexanoic acid Hexanoic acid 142-62-1 

Hippurate N-benzoyl-Glycine 495-69-2 

Isethionate 2-hydroxy-Ethanesulfonic acid 107-36-8 

Isopropylami
ne 

2-Propanamine 75-31-0 

Lactate 2-Hydroxy-Propanoic acid 50-21-5 

Lactobionate 4-O-ß-D-galactopyranosyl-D-Gluconic acid 96-82-2 

Laurate Dodecanoic acid 143-07-7 

Maleate 2-Butenedioic acid (2Z) 110-16-7 

Malonic acid Propanedioic acid 141-82-2 

Mandelate a-hydroxy-Benzeneacetic acid 90-64-2 

Mesylate Methanesulfonic acid 75-75-2 

Methiodide Iodomethane 74-88-4 

Methyl 
Bromide 

Bromomethane 74-83-9 

Methyl 
carbamate 

Carbamic acid methyl ester 598-55-0 

Monomethyl 
sulfate 

Sulfuric acid monomethyl ester 75-93-4 

Morpholine Tetrahydro-2H-1,4-oxazine 110-91-8 

Mucate Galactaric acid 526-99-8 

Myristate Tetradecanoic acid 544-63-8 

Naphthalenes
ulfonic 
acid 

 

1-Naphthalenesulfonic acid 

 

85-47-2 
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Napthylethan
amine 

1-Naphthaleneethanamine 4735-50-6 

Nicotinate 3-Pyridinecarboxylic acid 59-67-6 
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Common Organic Salts 
Systematic Name 

CAS Reg Number 

Oleate 9-Octadecenoic acid (9Z) 112-80-1 

Oxalate Ethanedioic acid 144-62-7 

Palmitate Hexadecanoic acid 57-10-3 

Pamoate 4,4’-methylenebis[3-hydroxy-2-
Naphthalenecarboxylic acid 

130-85-8 

Pentetate N,N’-bis[2-
[bis(carboxymethyl)amino]-Glycine 

67-43-6 

Phenpropinate Phenylpropanoic acid 501-52-0 

Phenylacetate Phenylacetic acid 103-82-2 

Phosphanilate (4-aminophenyl)-Phosphonic acid 5337-17-7 

Phthalate 1,2-Benzenedicarboxylic acid 88-99-3 

Picrate 2,4,6-trinitro-Phenol 88-89-1 

Picric acid 2,4,6-Trinitrophenol 29663-11-4 

Piperazine Piperazine 110-82-2 

Piperidine Hexahydropyridine 110-89-4 

Pivalate 2,2-dimethyl-Propanoic acid 75-98-9 

p-Nitrobenzoic 
acid 

4-Nitrobenzoic acid 62-23-7 

Probenate 4-[(dipropylamino)sulfonyl]-
Benzoic acid 

57-66-9 

Propionate Propanoic acid 79-09-4 

p-Salicylic acid 4-Hydroxybenzoic acid 99-96-7 

Pyridine Azabenzene 110-86-1 

Pyrrolidine Pyrrolidine 123-75-1 

Salicylate 2-hydroxy-Benzoic acid 69-72-7 

Sorbic acid 2,4-Hexadienoic acid 110-44-1 

Stearate Octadecanoic acid 57-11-4 

Stinoprate N-Acetyl-L-cysteine 616-91-1 

Suberic acid Octanedioic acid 505-48-6 

Succinate Butanedioic acid 110-15-6 

Sulfamate Aminosulfonic acid 5329-14-6 

Tartrate 2,3-dihydroxy-Butanedioic acid 87-69-4 

Terephthalate 1,4-Benzenedicarboxylic acid 100-21-0 

Tetrabutanami
nium 

1-Butanaminium, N,N,Ntributyl- 10549-76-5 

Tetraethanami
nium 

Ethanaminium, N,N,N-triethyl- 66-40-0 

Tosylate 4-methylbenzenesulfonic acid 104-15-4 

Triethanamine Ethanamine, N,N-diethyl- 121-44-8 

Triethanolami
ne 

2,2’,2’’-Nitrilotriethanol 102-71-6 

Trifluoro 
acetate 

Trifluoroacetic Acid 76-05-1 
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Trimethyl 
acetate 

Trimethyl acetic acid 75-98-9 

Tropate 3-Hydroxy-2-phenylpropanoic acid 529-64-6 

Undecylenate 10-Undecenoic acid 112-38-9 

Urea Carbamimidic acid 57-13-6 
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Common 
Organic Salts 

Systematic Name 
CAS Reg 
Number 

Valerate Pentanoic acid 109-52-4 

Xanthan
oic acid 

Xanthene-9-carboxylic acid 82-07-5 

 

TABLE X2-2. Common Inorganic Salts 
 

Common 
Organic Salts 

CAS Reg 
Number 

Aluminum (III) salt 7429-90-5 

Ammonium salt 14798-03-9 

Antimony salt 7440-36-0 

Barium (II) salt 7440-39-3 

Beryllium salt 7440-41-7 

Bismuth(III) salt  

Borate 11113-50-1 

Bromide 24959-67-9 

Cadmium (II) salt 7440-43-9 

Calcium(II) salt 7440-70-2 

Carbonate 463-79-6 

Cerium salt 7440-45-1 

Cerium (III) salt  

Cerium (IV) salt  

Cesium salt 7440-46-2 

Chlorate 7790-93-4 

Chloride 16887-00-6 

Chlorite 7790-93-4 

Chromium(III) salt 7440-47-3 

Cobalt salt 7440-48-4 

Cobalt(II) salt 7440-48-4 

Cobalt(III) salt 7440-48-4 

Copper salt 7440-50-8 

Copper(I) salt 7440-50-8 

Copper(II) salt 7440-50-8 

Diphosphate 14000-31-8 

Dysprosium(III) salt 7429-91-6 

Erbium(III) salt 7440-52-0 

Europium(III) salt 7440-53-1 

Tetrafluoroborate 16872-11-0 

Gadolinium(III) salt 7440-54-2 

Gallium(III) salt 7440-55-3 

Hexafluorophosphate 16919-18-9 
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Holmium(III) salt 7440-60-0 
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Common Organic Salts CAS Reg 
Number 

Hydrate  

Hydriodide 10034-85-2 

Hydrobromide 10035-10-6 

Hydrochloride 7647-01-0 

Hydrofluoride 7664-39-3 

Hydrogen cyanide 74-90-8 

Hydrogen phosphate  

Hydrogen sulfide  

Hypochlorite 14380-61-1 

Indium(III) salt 7440-74-6 

Iodide 20461-54-5 

Iron salt 7439-89-6 

Iron(II) salt 7439-89-6 

Iron(III) salt 7439-89-6 

Lanthanum(III) salt 7439-91-0 

Lead salt 7439-92-1 

Lead(II) salt 7439-92-1 

Lead(IV) salt 7439-92-1 

Lithium salt 7439-93-2 

Lutetium(III) salt 7439-94-3 

Magnesium(II) salt 7439-95-4 

Manganese(II) salt 7439-95-4 

Mercury salt 7439-97-6 

Mercury(I) salt 7439-97-6 

Mercury(II) salt 7439-97-6 

Neodymium(III) salt 7440-00-8 

Nickel(II) salt 7440-02-0 

Nitrate 7697-37-2 

Nitrite 7782-77-6 

Palladium(II) salt  

Perchlorate 7601-90-3 

Phosphate 14265-44-2 

Phosphonic Acid 13598-36-2 

Plutonium(VI) salt  

Potassium salt  

Praseodymium(III) salt 7440-10-0 

Rhodium(II) salt 7440-16-6 

Rubidium salt 7440-17-7 
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Ruthenium salt 7440-18-8 



174 Leadscope Client User Guide – Version 3.8 

Proprietary and Confidential 

 

Proprietary and Confidential 

 

 

 

Common Organic Salts CAS Reg 
Number 

Samarium(III) salt 7440-19-9 

Selenium(II) salt 7782-49-2 

Silicate 7699-41-4 

Silver salt 7440-22-4 

Sodium salt 7440-23-5 

Strontium salt 7440-24-6 

Sulfate 7664-93-9 

Sulfite 14265-45-3 

Sulfurous acid 7782-99-2 

Terbium(III) salt 7440-27-9 

Thallium salt 7440-28-0 

Thallium(I) salt 7440-28-0 

Thallium(III) salt 7440-28-0 

Thiosulfate  

Thorium salt 7440-29-1 

Thulium(III) salt 7440-30-4 

Tin salt 7440-31-5 

Tin(II) salt 7440-31-5 

Tin(IV) salt 7440-31-5 

Titanium(IV) salt 7440-32-6 

Uranium salt 7440-61-1 

Vanadium salt 7440-62-2 

Ytterbium(III) salt 7440-64-4 

Yttrium(III) salt 7440-65-5 

Zinc salt 7440-66-6 

Zinc(II) salt 7440-66-6 

Zirconium(IV) salt 7440-67-7 
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APPENDIX THREE 

 

 

 
 

Functional Groups Not Appearing as Class 

Headings 
 

 

 

Table X3-1: Functional groups not appearing as class headings 
 

Name Listed Under 

aminium groups  amines  

azine  misc nitrogen group  

aziridinies  heterocycle s 

azo  misc nitrogen group  

azoxy  misc  nitrogen group  

borate  boron goups  

carbamic acid  carbamate  

carbodiimide  misc nitrogen group  

carbonate  misc oxygen group  

cyanamide  misc nitrogen group  

cyanate  misc nitrogen group  

diazoalkane  misc nitrogen group  

diazonium  misc  nitrogen group  

dimethyleniminium  misc nitrogen group  

disulfide  misc sulfur group  

di thiocarbamate  carbamate, 
thioxomethyl  

dithiocarbamic acid  carbamate  

dithiocarboxy  thioxomethyl  

dithiocarboxylate  thiocarboxylate  

dithiocarboxylic acid  thiocarboxylic acid  

dithioformate  thiocarboxylate  

dithiocarboxylic acid  thiocarboxylic acid  

dithio formate  thiocarboxylate  

episulfides  heterocycles  

epoxides  heterocycles  
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formamide  carboxamide  

formate  carboxylate  
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Name Listed Under 

hydrazide  hydrazi ne 

hydrazone  hydrazine  

hydroperoxides  misc oxygen group  

imine oxide  misc nitrogen group  

iminium g roups  imines  

isothiocarbamate  carbamate  

isothiocyanate  misc nitrogen group  

isothiourea  misc nitrogen group  

isourea  misc  nitrogen group  

urea  misc nitro gen group  

nitramine  misc nitrogen group  

nitrate  misc nitrogen group  

nitrile imine  misc nitrogen gr oup  

nitrile oxide  misc nitrogen group  

nitrite  misc nitrogen group  

nitrone  misc nitrogen group  

nitrosamine  misc  nitrogen group  

oxime  hydroxylamine  

per oxides  misc oxygen group  

peroxyacid  misc oxygen group  

peroxyester  misc oxygen group  

phosphamide, c yc  phosphorous group  

phosphate  phosphorous group  

phosphate ion  phosphorous group  

phosphate, cyc -  phosphorous group  

phosphine  phosphorous group  

phosphi ne oxide  phosphorous group  

phosphite  phosphorous group  

phosphonamide  phosphorous group  

phosphonate  phosphorous group  

phosphonate ion  phosphorous group  

phosphonic acid, ester  phosphorous group  

phosphonium  phosphorous group  

phosphonium ylide  phosphoro us group  

phosphonodiamide  phosphorous group  

phosphoramide  phosphorous group  

phosphorodiamide  phosp horous group  

phosphorotriamide  phosphorous group  

quaternary amine  amines  

semicarbazide  urea  
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Name Listed Under 

semicarbazone  urea  

sulfamic acid and  

derivs.  

 

misc sulfur group  

sulfate ion  misc sulfur group  

sulfenic acid and  

derivs.  

 

misc sulfur grou p 

sulfinate ion  misc sulfur group  

sulfinic acid and  

derivs.  

 

misc sulfur group  

sulfuric acid ester  misc sulfur group  

thiocarbamic acid  carbamate  

thioc arboxy  carbonyl  

thiocyanate  misc nitrogen group  

thioformamide  thiocarboxamide  

thioformate  thiocarb oxylate  

thiohydrazide  hydrazine  

thiosemicarbazide  urea  

thiosemicarbazone  urea  

thiourea  thioxomethyl, urea  

triazane  misc nitrogen group  

triazene  misc nitrogen group  

trimethyl silyl  silicon groups  

trisulfide  misc sulfur group  
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APPENDIX FOUR 

 

 

 
 

Substituents 
 

 

Table X4-1: Substituents 
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APPENDIX FIVE 

 

 

 
 

Statistics 
 

 

In Leadscope, statistical techniques are used to evaluate the difference in the mean activity for a subset of 

structures versus the whole set. This value is reported as Z-Score in the Browser window. The method by 

which this value is obtained is the subject of this appendix. 
 

Background 

The dependence of the data on a particular variable (or variables) is called a distribution. One of the most 

common values or moments used to describe a distribution is the mean. If there are N data points and K 

variables, the mean, ȄɎ, about the kth variable, xjk, is defined as: 

 

 

Another important quantity that describes the variability or spread of the distribution about the mean is the 

variance. For N data points and K variables, the variance is defined as: 

 

 

The spread of the distribution about the mean is more often described in terms of the standard deviation, 

ˋΣ 
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which is the square root of the variance. 



189 Leadscope Client User Guide – Version 3.8 

Proprietary and Confidential 

 

Proprietary and Confidential 

 

 

 

Normal Distribution 

Many statistical analyses involve the assumption that the data follow a normal distribution. A normal 

distribution, also called a Gaussian, is a continuous probability curve that is symmetric about its center. The 

curve is described by the normal probability density function P(x): 

 

 

 

and characterized by two parameters; the population mean ȄɎ and the standard deviation .̀ Since P(x) is a 

probability distribution, the area below a given x is the probability that a randomly selected sample x is less 

than the mean. The total area under a Gaussian curve is 1. All Gaussian distributions have the same overall 

shape and are specified by their mean and standard deviation. 

 

 

Figure X5-1: Normal (Gaussian) Distribution 

All normal curves have the following properties: 

 

¶ ȄɎ ± ˋ contains 68.26% of the total area under the curve. 

¶ ȄɎ ± 2ˋ contains 95.46% of the total area under the curve. 

¶ ȄɎ ± 3ˋ contains 99.73% of the total area under the curve. 
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Any data set of random variables xj, j=1,2,...,N without an inherent scale is approximately a normal (Gaussian) 

distribution for a large enough sample size N. 
 

Comparison of Two Distributions 

 

The mean potency of the subset A, ȄɎA, is given by: 

 

 

 

 

The mean potency, ȄɎB, of compounds without structural feature y is determined by replacing A with B in 

equation (3) above. 
 

The mean potency for the entire set of compounds is given by: 

 

 

The adjusted variance of the distribution for a particular structural feature y is: 

 

 

Equation (7) is equivalent to (2) weighted by . When working with subsets, it is useful to express the 

distance between the total mean and the mean of the subset, in units of the standard deviation. This is 

referred to as the z-statistic or z-score, defined as where xsample = ȄɎA and σ is given by the square root of 

equation (7). 
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APPENDIX SIX 

 

 

 
 

Client Installation Instructions 
 

 

Overview 

The Leadscope Client installer is available as a Microsoft™ Windows compatible executable (.exe) file that can 

be pre-configured to include the Leadscope Enterprise (LSE) or Leadscope Hosted (LSH) Server connection 

settings, the client license file, and local databases. The installer can also be run without these resources and 

configured later. This document details how to install the Leadscope Client on an end-user PC and what to 

expect from the Leadscope Client installation. Leadscope clients covered by this document include LSE, LSH, 

Leadscope Personal (LSP), the subscription version of the Leadscope Model Applier (LSMA), and Leadscope 

Model Applier Enterprise (LSMA-E). The topics covered include the following. 

 

¶ Leadscope Client Requirements 

 

¶ Leadscope Client Structure 

 

¶ Leadscope Client Installation Steps 

¶ Leadscope Client Migration 

 

¶ Leadscope Client Configuration 

 

¶ Leadscope Client Upgrade 
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Leadscope Client Requirements 

The requirements for the 32-bit and 64-bit Leadscope Clients are listed in Tables X6-1 and X6-2, 

respectively. 

 

Requirement Minimum Value 

System 

Architecture  

Processor: Intel (x86), AMD64, and 

Intel EM64T  

 

Note:  Leadscope provides 32 - bit (Windows x86) 

and 64- bit (Windows x64) versions of the LSE 

Client. The 32- bit LSE Client runs on the 32-  

bit version of Windows on either x86 or x64 

hardware.  

Requirement Minimum Value 

Physical memory 

(RAM) 

1 GB minimum  

Virtual memory  Double the amount of RAM  

Hard disk space  Minimum 1GB available disk space (LSE, LSH, 

LSP, LSMA - E)  

 

Minimum 10GB available disk space 

(LSMA)  

Video adapter  256 colo rs  

Screen 

Resolution  

1024 X 768 minimum  

Operating System  Microsoft Windows 7, 8, or 10  

Table X6-1: Leadscope version 3.3 32-bit Client requirements 
 

Requirement Minimum Value 

System 

Architecture  

Processor: AMD64 and Intel EM64T  

Physical memory 

(RAM) 

1 GB minimum  

Virtual memory  Double the amount of RAM  

Hard disk space  Minimum 1GB available disk space 

(LSE, LSH, LSP, LSMA - E)  

 

Minimum 10GB available disk space 

(LSMA)  
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Video adapter  256 colors  

Screen Resolution  1024 X 768 minimum  

Operating System  Micro so f t Windows 7, 8, or 10  

Table X6-2: Leadscope version 3.5 64-bit Client requirements 

 

Leadscope Client Structure 

Following a successful installation, the Leadscope Client will be organized on the local PC in the manner 

outlined in the tables below. 
 

In %PROGRAMFILES%\ [Leadscope Client Installation Folder] : 

Directory Files 

 

\ bin  

the location of executable binary files 

organized by OS type (i.e., win32, 

win64)  

\ ext  
external programs used by the LSE Client 

including the JVM  

\ lib  LSE Client library files  

\ r esources  LSE Client resources files  

Table X6-3: Leadscope Client %PROGRAMFILES% organization 

In %LOCALAPPDATA%\ [ Leadscope Client Installation Folder] : 

 

Directory Files 

\ projects  location of the LSE Client personal 

database  

files  

Table X6-4: Leadscope Client %LOCALAPPDATA% organization 

In %USERPROFILE%\ Documents \ [ LSE Client Installation Folder] : 

 

Directory Files 

\ resources  Leadscope - specific database resources, 

files  and settings  

 

\ resources \ sett

ings  

location of LSE Client license file 

( license.xml)  and main preferences file 

( LSEPreferences.xml )  
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\ export  the default export location  

\ log  location of the LSE Client log files  

\ updates  location of Leadscope content_loader 

archive  

files  

\ bundled_update

s 

location of Leadscope content_loader 

archive  

file s used during database migration  

Table X6-5: Leadscope Client %USERPROFILE% organization 

Executable applications and utilities available in Leadscope Client are listed in Table X6-6. These files will be 

installed to the %PROGRAMFILES%\ [Leadscope Client In st allation Folder] . 

 

Directory Files 

\ bin 

\ <platform> \ lse_client_console.

exe  

LSE Client executable file  

\ bin \ <platform> \ dbupgrade.exe  upgrade utility for the 

local  

personal database  

Directory Files 

 

\ bin \ <platform> \ propertyCalcula

tor.exe  

command- line  utility to 

calculate  

Leadscope Calculated properties for 

a chemical structure  

 

\ bin \ <platform> \ structureChecke

r.exe  

command line utility to 

validate chemical 

structure files for import 

to Leadscope  

 

 

\ bin \ <platform> \ structureFilter

.exe  

command line util i t y for filtering 

chemical structure files based on  a 

number of parameters (such as by 

ID, by chemical property, by line 

number,  etc.)  

\ bin \ <platform> \ structureViewer

.exe  

a standalone chemical 

structure  

file interactive 

spreadsheet  

Table X6-6: Leadscope Client %PROGRAMFILES% executable files 

Configurable resources required by the Leadscope Client include the files and directories listed in Table X6-7. 

For a Windows client installation, these files are located in the 

%USERPROFILE%\ Documents \ Leadscope \ [Lead scope Client Installation Folder] . 
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Directory Files 

 

 

\ resources \ settings \ LSEPrefere

nces.xml  

the main settings and preferences 

file for the LSE Client, the server 

URL, personal database JDBC 

connection URL, and personal  database  

location are  stored here 

al ong with other user 

preferences  

\ export  the default export location  

 

 

\ log  

location of the LSE Client log 

files, by default the last 4 client  

log files are saved and numbered,  for 

instance the latest log file is  named 

lse_client_console.exe - 0.log  

Table X6-7: Leadscope Client configurable resources 
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Leadscope Client Installation Steps 

Step One: Agree to license (Leadscope Model Applier only) 

The first step is to read and agree to the Leadscope License Agreement if you are installing the LSMA client. 

 

 

Figure X6-1: LS Client installation ς Model Applier license agreement 

Step Two: Designate installation location 

The first step is to choose an installation location for the Leadscope Client, the default and preferred 

installation folder is the %PROGRAMFILES%\ [Leadscope Client installation folder] . 
 

 

Figure X6-2: LS Client installation - choose install location 
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Step Three: Choose Start Menu folder 

After choosing the installation location, you will be asked to designate a Start Menu folder. The default Start 

Menu folder will be the Leadscope Client product name, version, and platform identifier (for instance, 

Leadscope Enterprise Client v3.8-win64). The version number specified is the major and minor version 

numbers not including the specific point release or build numbers (for instance, version 3.8.0 versus version 

3.8.1). 
 

 

Figure X6-3: LS Client installation - choose Start Menu folder 

Step Four: Installation progress & finished 

Now the Leadscope Client will be installed, and the progress updated. When the installation has completed, 

click the Close button to exit the installer. 
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Figure X6-4: LS Client installation - installation progress 

 

Leadscope Client Migration (Leadscope Enterprise, Hosted, and 

Personal) 
When it is first launched, the newly installed client will check the Windows Registry for any existing 

Leadscope Client installations. If at least one existing client is found, you will be prompted to choose whether to 

migrate the existing database to the newly installed client or to use the database included with the client 

installation file. If you wish to migrate, you can select the existing client from the migration dialog drop- down 

menu and then click “OK”. After the database is copied any pending database structure updates will be 

applied and then the “bundled updates” folder checked for any content to load to the database. 
 

Leadscope Client Configuration 

The networked Leadscope applications, Leadscope Hosted and Enterprise, require the Leadscope Client 

provide a valid Leadscope Server URL in order to connect successfully. 

 

Add LS Server URL to LS Client using the LS Client interface 

After the LS Client has been installed the server URL can be added using the Tools -> Server Settings option in 

the LS Client interface. 

 

In the Tools -> Server Settings window, select the New button (Figure X3-5). 
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Figure X6-5: Add LSE Server URL to LSE Client 

Next, for a Leadscope Enterprise Client, in the Server Settings ς new host:1 window enter the host name for 

the LS Server and click OK in both windows. 
 

 

Figure X6-6: LS Client configuration - LSE Server Settings 

For a Leadscope Hosted Client, enter the Leadscope Server host name and click the Use SSH checkbox then 

enter the SSH Host and SSH User. 
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Figure X6-7: LS Client configuration - LSH Server Settings 

You will be prompted to restart the client, click OK. 

 

 

Figure X6-8: Restart client 

The LS Client will now attempt to connect to the specified LSE Server URL upon restart. 

 

Add LS Server URL to LS Client manually 

You can also add the Leadscope Server URL to the LS Client manually by editing the 

%USERPROFILE%\Documents\Leadscope\ [LSE Client Installation Folder] 

\ resources\settings\LSEPreferences.xml file. 
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First edit the file in an editor that will preserve the formatting (such as WordPad), then locate the UserInfo > 

requestedServerUrls key and enter <LSE Server host name>:1;lan as the value associated with the following 

key. 

 

<key name="UserInfo">  

 

...  

 

<key name="requestedServerUrls">  

<value type=" java.lang.String">< LSE Server 

host name>:1;lan </value > 
 

</k ey>  

 

...  

 

Save the file in the original XML format and then restart the LSE Client and it will attempt to connect to the 

configured LSE Server URL. 
 

Leadscope Client Upgrade 

This section details the upgrade procedures for the Leadscope Client. Typically, Leadscope releases several 

point releases a year to introduce minor features and/or address bugs and known issues. Point release 

upgrades (for instance, upgrading from version 3.8.1 to version 3.8.2) normally involve the replacement of 

the certain Java library files. Major and minor release upgrades normally require the installation of a new 

Leadscope Client as the underlying application structure may have changed in a manner that cannot be 

addressed by the normal upgrade facility. 
 

Point release upgrades can be upgraded from the Leadscope, Inc. servers (via an HTTPS connection to 

www.leadscope.com) for standalone clients such as Leadscope Personal or the Leadscope Model Applier. 

These applications will check for available upgrades at startup and prompt the user. The Leadscope Hosted 

and Enterprise Clients can be upgraded using the Leadscope Server client auto-update facility and prompt 

the user to upgrade when connecting to the server. 
 

Alternatively, the Leadscope Client can be upgraded manually by copying the appropriate upgrade files to 

the 

%USERPROFILE%\Documents\Leadscope\ [LS Client Installation Folder]\updates folder. The upgrade is 

distributed in an Updater executable (.exe) file. 
 

  

http://www.leadscope.com/
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Updating the Client License 

The LS Client includes a local license file located at %USERPROFILE%\Documents\Leadscope\ [LS Client 

Installation Folder]\ resources\settings\ license.xml. On occasion, it is necessary to update the client license 

file. For any LS Client, this can be done by directly replacing the license file when the application is stopped 

For the Model Applier, the license can also be replaced while the application is running by browsing to the 

About section and selecting the Replace License File option (Figure X6-9). Both the LSE and LSH clients can 

also have their license files remotely replaced upon connecting to the server. 

 
 

Figure X6-9: Replace license file option in the Model Applier 
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APPENDIX SEVEN 

 

 

 
 

Calculated Properties 
 

 

Overview 

Leadscope calculates nine physicochemical properties for every chemical loaded by the application. In 

addition to the intrinsic value of these properties they are also commonly used as data set filters or QSAR 

model predictors. This appendix describes each of these properties, including: 
 

ALogP 

Hydrogen Bond Acceptors 

Hydrogen Bond Donors 

Lipinski Score 

Molecular Weight 

Parent Molecular Weight 

Parent Atom Count 

Polar Surface Area 

Rotatable Bonds 

 

Identification of Parent Substance 

To calculate many properties, such as Parent Molecular Weight, salts must be removed. The following steps 

identify the parent molecule in a multi-component substance: 
 

1. Remove equivalent fragments 

2. Remove water, H+, O-, H3O+ 

3. Delete all inorganic single atom fragments 

4. Neutralize the structure 

5. Delete all components comprised of only inorganic atoms 

6. Remove (organic) salt fragments using a pre-defined dictionary of salts; e.g., acetate, tosylate, 

etc. (see Appendix 2) 

7. For ALogP and PSA, identify zwitterions 
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Calculated Property Definitions 

1. Molecular Weight: The sum of the atomic masses of all the atoms in the molecule 

2. Parent Molecular Weight: The sum of the atomic masses of all the atoms in the parent 

molecule 

3. Parent Atom Count: The number of all the atoms in the parent molecule 

4. Rotatable Bonds: The number of single, non-terminal acyclic bonds 

5. Hydrogen Bond Acceptors (HBA) : 

a. Any doubly bonded oxygen 

b. Any singly bonded oxygen, such as anion A-O- or hydroxyl A-OH 

c. Uncharged imine, nitrile, or aromatic N. Examples of imines include C=NH, or C=N-Ak; 

aromatic N includes ARO -N-ARO, where both ARO-N bonds are cyclic, aromatic 

d. An ether oxygen in the form C-O-C, where neither C is substituted by a doubly-bonded 

N, S, or O; e.g., neither C is part of a carbonyl 

e. at most one C is aromatic 

f. the O is acyclic e.g., C-O-C is cyclic, both C are sp3 hybridized 

g. Any doubly bonded sulfur in thioxomethyl C=S, where S has no other attachments 

6. Hydrogen Bond Donors (HBD): 

a. Any OH not part of an oxo acid (A hydroxyl of an oxo acid is considered ionized at 

physiological pH and will be recognized as an HBA.) 

b. Any NH not in a tetrazole or N-trifluoromethyl-sulfonamide 

7. Polar Surface Area: Molecular polar surface area (PSA) i.e., surface attributed to polar atoms, is 

a descriptor that has been shown to correlate well with passive molecular transport through 

membranes and, therefore, allows prediction of transport of drugs. 1 

8. ALogP: Molecular hydrophobicity (lipophilicity), usually quantified as log P (the logarithm of 1- 

octanol/water partition coefficient) 2 

9. Lipinski Score: Lipinski’s Rule of Five is a simple way to assess a compound’s oral bioavailability 

based on upper limits of the compound’s logP, Molecular Weight, and the Number of Hydrogen 

Bond Donors and Acceptors.3 This score has a value between 0 – 4 and indicates the number of 

the following rules that are violated: 

a. if ALogP is greater than or equal to 5.0 - add 1; 

b. if Parent Molecular Weight is greater than or equal to 500 - add 1; 

c. if the sum of N+O atoms is greater than 10 - add 1; 

d. if the sum of NH + OH is greater than 5 - add 1. 
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